Bug 144337 - Unable to send combined correspondence (send emails) using Writer LO Fresh 7.2.0
Summary: Unable to send combined correspondence (send emails) using Writer LO Fresh 7.2.0
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.2.0.4 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
: 147593 (view as bug list)
Depends on:
Blocks: Mail-Merge
  Show dependency treegraph
 
Reported: 2021-09-06 17:15 UTC by Luciano Ferrer
Modified: 2022-08-24 06:08 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Luciano Ferrer 2021-09-06 17:15:15 UTC
Description:
Recently I have updated my gnu linux system (it is a manjaro mate flavor, so... based on archlinux) and libreoffice went 7.2.0

Today I realized was unable to send emails (you know the "combine correspondence" using a database etc, no idea how it is written in english)
The SMTP was properly configured, and it was working great a week ago... but now Writer combine all the emails and starts to send........ but, never sends anything, just keeps at 0 (zero)

No error reported, just hangs there until I stop it...

How this help, no idea how to make it more informative

PD: I solved it uninstalling Fresh and now using Still... (btw, the combine correspondence wizard changed a little to?)


Steps to Reproduce:
1. combine some correspondence (email)
2. try to send it
3. not gonna happen

Actual Results:
emails never went out, just hang at 0
no error reported

Expected Results:
emails being sent, counter increasing until all is sent


Reproducible: Always


User Profile Reset: No



Additional Info:
...
Comment 1 m.a.riosv 2021-09-06 20:20:45 UTC
Please test with a clean profile, Menu/Help/Restart in Safe Mode
Comment 2 Luciano Ferrer 2021-09-06 23:39:13 UTC
Thanks I did it now, and the same happens...

I configured the email settings at Options, Writer, started the combine email wizard, added an .ods file, selected the detination email column, added some fields in the text... and hit send, selected TO emails, added som subject...

It freezes at 0 of X (in this case was just 4, some emails I own)
Comment 3 cpohle 2022-02-23 10:52:39 UTC
I can confirm this for

Version: 7.3.0.3 / LibreOffice Community
Build ID: 0f246aa12d0eee4a0f7adcefbf7c878fc2238db3
CPU threads: 4; OS: Mac OS X 10.15.7; UI render: Skia/Metal; VCL: osx
Locale: de-DE (de_DE.UTF-8); UI: de-DE
Calc: threaded

Using LO Version: 6.3.6.2, e-mail merge works fine as expected.
Comment 4 Timur 2022-03-05 16:27:34 UTC
Do you send to all or just to a range, so that would be bug 138398?
Comment 5 Reto 2022-03-20 15:13:07 UTC
Same behaviour for me: after clicking "send documents" it opens the dialog with the transfer status and freezes no matter whether it's for one, a range of or all documents. LO 7.2.5 worked fine. This behaviour started after upgrading to 7.3.0 and still consists with 7.3.1:

Version: 7.3.1.3 / LibreOffice Community
Build ID: 30(Build:3)
CPU threads: 8; OS: Linux 5.16; UI render: default; VCL: gtk3
Locale: de-CH (de_CH.UTF-8); UI: de-DE
Debian package version: 1:7.3.1-1+b2
Calc: threaded

I think I already met this in the past, in fact when changing to a new branch. Maybe that helps.
Comment 6 Xisco Faulí 2022-03-21 11:29:19 UTC
Thank you for reporting the bug. To be certain the reported issue is not related to corruption in the user profile, could you please reset your Libreoffice profile ( https://wiki.documentfoundation.org/UserProfile ) and re-test?

I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the issue is still present
Comment 7 Luciano Ferrer 2022-03-21 11:43:00 UTC
As I said in comment 2, I have tested it with a clean profile
Comment 8 Timur 2022-03-21 12:08:35 UTC
I didn't test, but I set Major, as the feature doesn't work. Please search and test similar bugs, it's helpful to mark duplicate or connect via See Also. 
Searching also closed bugs may show the culprit, as this is likely a regression.
Comment 9 Xisco Faulí 2022-03-21 12:11:30 UTC
(In reply to Timur from comment #8)
> I didn't test, but I set Major, as the feature doesn't work. Please search
> and test similar bugs, it's helpful to mark duplicate or connect via See
> Also. 
> Searching also closed bugs may show the culprit, as this is likely a
> regression.

doesn't make sense unless you can reproduce it
Comment 10 Reto 2022-03-21 13:44:57 UTC
Reproduction is given according to my testing (see my comment). That's not enough to leave it on major and high?
Comment 11 Timur 2022-04-06 06:48:38 UTC
*** Bug 147593 has been marked as a duplicate of this bug. ***
Comment 12 Timur 2022-04-06 06:54:03 UTC
This is a LO feature not working for 4 users (for such a feature requiring set-up of e-mail system, really enough), surely should be High priority. 
There were some fixes in bug 148384 (and bug 148382 and bug 148338), you may try from tomorrow with daily master 7.4+ https://dev-builds.libreoffice.org/daily/master/current.html.
Comment 13 Timur 2022-04-10 18:41:28 UTC Comment hidden (obsolete)
Comment 14 Buovjaga 2022-04-10 19:02:04 UTC
(In reply to Timur from comment #13)
> Buovjaga, if you have setup for this, please see.

Thanks, but I'll wait for the affected users to rather test with 7.4
Comment 15 Timur 2022-04-28 13:43:32 UTC
There were multiple reports for Mail Merge, saying it stopped working in version 6.4, 7.0, 7.2, 7.3.
Also here, report was for 7.2 but confirmations for 7.3. 
I tested in 7.3 and confirmed the problem, not sending, staying 0, status frozen.
But in master 7.4+ all is working. 
Problem is that somehow it's not backported to 7.3, even master still has problems.
Comment 16 Timur 2022-04-28 13:45:49 UTC
Nah, 7.3 bibisect repo is 7 weeks old, all issues should be resolved in 7.3.3. 
Plese download and test, it's available as Prerelease.
Comment 17 raal 2022-08-23 10:31:06 UTC
hello, tested with Version: 7.3.5.2 / LibreOffice Community
Build ID: 30(Build:2)
CPU threads: 4; OS: Linux 5.15; UI render: default; VCL: gtk3
Locale: cs-CZ (cs_CZ.UTF-8); UI: cs-CZ
Ubuntu package version: 1:7.3.5-0ubuntu0.22.04.1
Calc: threaded
and I can reproduce the bug. I'll try master later.
Comment 18 raal 2022-08-23 11:29:15 UTC
Tested with Version: 7.5.0.0.alpha0+ / LibreOffice Community
Build ID: 27892a5e12dada80226f778ab2bd14b1bdaab58a
CPU threads: 4; OS: Linux 5.15; UI render: default; VCL: gtk3
Locale: cs-CZ (cs_CZ.UTF-8); UI: en-US
Calc: threaded

and in this version it works correctly, e-mails was send.
Comment 19 Reto 2022-08-23 17:51:25 UTC
It also works for this version:

Version: 7.4.0.3 / LibreOffice Community
Build ID: 40(Build:3)
CPU threads: 8; OS: Linux 5.18; UI render: default; VCL: gtk3
Locale: de-CH (de_CH.UTF-8); UI: de-DE
Debian package version: 1:7.4.0~rc3-1
Calc: threaded

Assuming this bug will not be fixed for versions before 7.4 the bug can be closed.