Bug 144342 - Writer makes a .docx table take more space than in Word
Summary: Writer makes a .docx table take more space than in Word
Status: RESOLVED DUPLICATE of bug 136617
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.2.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2021-09-06 20:52 UTC by happytoast27
Modified: 2021-09-08 07:25 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments
How it looks on Word (86.77 KB, image/png)
2021-09-06 20:54 UTC, happytoast27
Details
How it looks on Writer (388.17 KB, image/png)
2021-09-06 20:55 UTC, happytoast27
Details
word file (18.44 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2021-09-06 20:56 UTC, happytoast27
Details
Word 2016 opening the file in 3 pages (108.36 KB, image/png)
2021-09-06 21:49 UTC, Mike Kaganski
Details
word file Compared MSO LO (178.86 KB, image/png)
2021-09-07 15:12 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description happytoast27 2021-09-06 20:52:27 UTC
Description:
When viewing a .docx file with Microsoft Word, the document is 2 pages total. When I try with Writer, the document goes to 3 pages, with what I'm guessing is a problem with the merge table cells.



Steps to Reproduce:
1.Open file with Writer
2.See that the merged cells have a slight grey line.
3.Notice that the table takes one extra line compared if you were to open it with Microsoft Word.

Actual Results:
A 3 page document with the last item on the table going over to the second page.

Expected Results:
A 2 page document with the table not appearing on the second page.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 7.2.0.4 (x86) / LibreOffice Community
Build ID: 9a9c6381e3f7a62afc1329bd359cc48accb6435b
CPU threads: 12; OS: Windows 10.0 Build 19043; UI render: Skia/Vulkan; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: CL
Comment 1 happytoast27 2021-09-06 20:54:14 UTC
Created attachment 174835 [details]
How it looks on Word
Comment 2 happytoast27 2021-09-06 20:55:17 UTC
Created attachment 174836 [details]
How it  looks on Writer
Comment 3 happytoast27 2021-09-06 20:56:46 UTC
Created attachment 174838 [details]
word file
Comment 4 Mike Kaganski 2021-09-06 21:49:00 UTC
Created attachment 174839 [details]
Word 2016 opening the file in 3 pages

Can't repro the "When viewing a .docx file with Microsoft Word, the document is 2 pages total" part using Word 2016.
Comment 5 Timur 2021-09-07 15:12:04 UTC
Created attachment 174860 [details]
word file Compared MSO LO

No repro LO 7.0. So regression in 7.1. Repro LO 7.3+-
Seen also in Windows (where Calibri font is available, so difference is not because of font).
Comment 6 happytoast27 2021-09-07 17:24:03 UTC
(In reply to Mike Kaganski from comment #4)
> Created attachment 174839 [details]
> Word 2016 opening the file in 3 pages
> 
> Can't repro the "When viewing a .docx file with Microsoft Word, the document
> is 2 pages total" part using Word 2016.

On the Account option it says I'm using the 365 Apps for enterprise.
Comment 7 Timur 2021-09-08 07:25:05 UTC
Bibisect 71 Linux:

commit a152d314c649de94c379eec2e780f08fc50d8b94
Date:   Thu Aug 20 10:45:38 2020 +0200 bf3124cdf61b40c94ba117a76f1b63dabdfd528e
pre b39364492c7cbe34923e0d0755db8737b7d6225a

author	László Németh <nemeth@numbertext.org>	2020-08-19
tdf#135187 DOCX import: fix table style at character formatting
applied also on paragraph level during import.

Regression from commit 4d5c0eaf3e0d3d3bcd9e691fffee19b75f3d6631
(tdf#118812 DOCX import: fix table style preference – part 2)

See also commit 5ac6f02fdc6015a5d78071570dee310febf95fc6
(tdf#105215 DOCX import: fix paragraph-length direct formatting).


This is already reported so I duplicate.

*** This bug has been marked as a duplicate of bug 136617 ***