Bug 144363 - Experimental 4k+ columns bugs - 1) Merged / Big cells are confused in view, 2) cannot delete rows
Summary: Experimental 4k+ columns bugs - 1) Merged / Big cells are confused in view, 2...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.3.0.0 alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Calc-large-spreadsheets
  Show dependency treegraph
 
Reported: 2021-09-07 19:37 UTC by elias estatistics
Modified: 2022-02-22 06:40 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Experimental 4k+ columns bugs (12.54 KB, application/vnd.oasis.opendocument.spreadsheet)
2021-09-07 19:37 UTC, elias estatistics
Details
delete rows as whole bug wtih 4k+ column enable (149.41 KB, application/vnd.oasis.opendocument.spreadsheet)
2021-09-17 21:34 UTC, elias estatistics
Details

Note You need to log in before you can comment on or make changes to this bug.
Description elias estatistics 2021-09-07 19:37:49 UTC
Created attachment 174867 [details]
Experimental 4k+ columns bugs

Experimental 4k+ columns bugs - 1) Merged / Big cells are confused in view, 2) cannot delete rows


Experimental 4k+ columns bugs

First:

1) Try to write or edit, or change color or change the size of cells. 
 - You cannot sya excactly where data lies. "They are blurred" with other cells. 
- If you change the standard size of cell or font cell content in view is "blurred" in almost all near cells. 

Second: 

1) Try to delete a banch of Rows or Columns (as whole). 
2) Calc is exited abnormally.
Comment 1 raal 2021-09-17 14:25:38 UTC
I can confirm first problem, but cannot reproduce second

Version: 7.3.0.0.alpha0+ / LibreOffice Community
Build ID: 55adeb1c3fbcf32c7c44a3f0c310b56298f551f9
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: cs-CZ (cs_CZ.UTF-8); UI: en-US
Calc: threaded Jumbo
Comment 2 elias estatistics 2021-09-17 21:34:15 UTC
Created attachment 175098 [details]
delete rows as whole bug wtih 4k+ column enable

delete rows as whole bug wtih 4k+ column enable

Please select with mouse rows 37 to 52 and delete them as whole

eg. Right click on selection of rows --> select DELETE ROWS. 

Libre calc is exited ONLY in 4k+ enable thing.
Comment 3 raal 2021-09-17 22:25:14 UTC
I can reproduce the crash with Version: 7.3.0.0.alpha0+ / LibreOffice Community
Build ID: e7a40c0ded1ba26b6b8f3da5a0b894e9c7ee7a96
CPU threads: 4; OS: Linux 5.11; UI render: default; VCL: gtk3
Locale: cs-CZ (cs_CZ.UTF-8); UI: en-US
Calc: threaded Jumbo
Comment 4 Timur 2022-02-19 14:58:05 UTC
This bug needs a retest for crash, and check in other reports for blur.
Comment 5 elias estatistics 2022-02-19 21:55:03 UTC
libre office 7.4. in linux bullseye 11 blurrings happens too.
Comment 6 elias estatistics 2022-02-19 21:55:37 UTC Comment hidden (obsolete)
Comment 7 Luboš Luňák 2022-02-21 15:51:06 UTC
I either don't understand the description of the problem or I can't reproduce with current master.
Comment 8 raal 2022-02-21 16:08:10 UTC
Vannot reproduce now Version: 7.4.0.0.alpha0+ / LibreOffice Community
Build ID: 0723b41bed9bb4ad50d2993744a60177966d1a21
CPU threads: 4; OS: Linux 5.13; UI render: default; VCL: gtk3
Locale: cs-CZ (cs_CZ.UTF-8); UI: en-US
Calc: threaded Jumbo
Comment 9 Timur 2022-02-21 17:57:56 UTC
Raal, you reproduced both problems with older LO and now none? 
Why didn't you close this?
Comment 10 elias estatistics 2022-02-22 00:02:49 UTC
I can confirm too for 7.4, blurring was fixed.

(cause i have 2 edition in my pc, i confused before). I retested and all ok. 
you can close this bug.
Comment 11 Timur 2022-02-22 06:40:59 UTC
ok, but next time please keep in mind rule "one issue per bug" and report after search in existing bugs and if possible after test with master. thanks.