Bug 144434 - LibreOffice 7.1.6.2 fails to start if Skia is enabled.
Summary: LibreOffice 7.1.6.2 fails to start if Skia is enabled.
Status: RESOLVED DUPLICATE of bug 144598
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
7.1.6.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-09-10 19:46 UTC by jmah
Modified: 2021-11-17 13:44 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
skia.log - LibreOffice 7.1.6.2 does not start. (37 bytes, text/plain)
2021-09-11 19:25 UTC, jmah
Details
opengl_device.log - LibreOffice 7.1.6.2 starts. (318 bytes, text/plain)
2021-09-11 19:28 UTC, jmah
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jmah 2021-09-10 19:46:33 UTC
Description:
When launching LibreOffice 7.1.6.2, Libreoffice does not start.  There are
no active LibreOffice processes.  See Windows event logs in the 'Other info'
section below.

This may be similar to Bug 144174, reported for LibreOffice 7.2.1.1.


Steps to Reproduce:
Scenario 1 :
  1. Clean Install of LibreOffice 7.1.6.2.
  2. Start LibreOffice.

Scenario 2 :
  1. Clean install of LibreOffice 7.1.5.2.
  2. Start LibreOffice.
     Verify that the following option is checked (enabled) by default.
       Tools/Options/LibreOffice/View/'Use Skia for all rendering'
  3. Stop LibreOffice.
  4. Update LibreOffice with 7.1.6.2.
  5. Start LibreOffice.

Scenario 3 :
  1. Clean install of LibreOffice 7.1.5.2.
  2. Start LibreOffice.
     Verify that the following option is checked (enabled) by default.
       Tools/Options/LibreOffice/View/'Use Skia for all rendering'
  3. Disable (uncheck) Skia in the following option.
       Tools/Options/LibreOffice/View/'Use Skia for all rendering'
  4. Stop LibreOffice.
  5. Update LibreOffice with 7.1.6.2.
  6. Start LibreOffice.
     Verify that the following option is unchecked (disabled).
       Tools/Options/LibreOffice/View/'Use Skia for all rendering'

Scenario 4 :
  1. Continue from scenario 3.
  2. Enable (check) Skia in the following option.
       Tools/Options/LibreOffice/View/'Use Skia for all rendering'
  3. Stop LibreOffice.
  4. Start LibreOffice.

Note : Used a non-admin account in Windows 10.


Actual Results:
Scenario 1 ; LibreOffice 7.1.6.2 cannot start.
Scenario 2 : LibreOffice 7.1.6.2 cannot start.
Scenario 3 : LibreOffice 7.1.6.2 starts properly.
Scenario 4 : LibreOffice 7.1.6.2 cannot start.


Expected Results:
All scenarios : LibreOffice starts properly.



Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
PC Platform Info :
  CPU: AMD Phenom II X6 1090T
  Memory: 8 GB
  GPU: AMD Radeon HD 5870, GPU-Z reports that OpenGL 4.5 is supported.
  OS:  Windows 10 Home x64 Build 19042.1165 (20H2)

  Note that the PC hardware is over ten years old.  But its performance
  is still very good.

LibreOffice versions :

  Version: 7.1.5.2 (x64) / LibreOffice Community
  Build ID: 85f04e9f809797b8199d13c421bd8a2b025d52b5
  CPU threads: 6; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
  Locale: en-CA (en_CA); UI: en-US
  Calc: CL

  Version: 7.1.6.2 (x64) / LibreOffice Community
  Build ID: 0e133318fcee89abacd6a7d077e292f1145735c3
  CPU threads: 6; OS: Windows 10.0 Build 19042; UI render: default; VCL: win
  Locale: en-CA (en_CA); UI: en-US
  Calc: CL

Windows event logs when LibreOffice 7.1.6.2 cannot start.

--------------------------
Log Name:      Application
Source:        Application Error
Date:          2021-09-10 1:47:04 PM
Event ID:      1000
Task Category: (100)
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      PC
Description:
Faulting application name: soffice.bin, version: 7.1.6.2, time stamp: 0x6135e2a5
Faulting module name: skialo.dll, version: 7.1.6.2, time stamp: 0x61353cf8
Exception code: 0xc000001d
Fault offset: 0x000000000052b9c0
Faulting process id: 0x159c
Faulting application start time: 0x01d7a66bdd9b3296
Faulting application path: C:\Program Files\LibreOffice\program\soffice.bin
Faulting module path: C:\Program Files\LibreOffice\program\skialo.dll
Report Id: 6bbfb3f0-c27b-49e5-b5ca-0193129599ee
Faulting package full name: 
Faulting package-relative application ID: 
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Application Error" />
    <EventID Qualifiers="0">1000</EventID>
    <Version>0</Version>
    <Level>2</Level>
    <Task>100</Task>
    <Opcode>0</Opcode>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2021-09-10T17:47:04.8538015Z" />
    <EventRecordID>30873</EventRecordID>
    <Correlation />
    <Execution ProcessID="0" ThreadID="0" />
    <Channel>Application</Channel>
    <Computer>PC</Computer>
    <Security />
  </System>
  <EventData>
    <Data>soffice.bin</Data>
    <Data>7.1.6.2</Data>
    <Data>6135e2a5</Data>
    <Data>skialo.dll</Data>
    <Data>7.1.6.2</Data>
    <Data>61353cf8</Data>
    <Data>c000001d</Data>
    <Data>000000000052b9c0</Data>
    <Data>159c</Data>
    <Data>01d7a66bdd9b3296</Data>
    <Data>C:\Program Files\LibreOffice\program\soffice.bin</Data>
    <Data>C:\Program Files\LibreOffice\program\skialo.dll</Data>
    <Data>6bbfb3f0-c27b-49e5-b5ca-0193129599ee</Data>
    <Data>
    </Data>
    <Data>
    </Data>
  </EventData>
</Event>

--------------------------
Log Name:      Application
Source:        Application Error
Date:          2021-09-10 1:47:04 PM
Event ID:      1005
Task Category: (100)
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      PC
Description:
Windows cannot access the file  for one of the following reasons: there is a problem with the network connection, the disk that the file is stored on, or the storage drivers installed on this computer; or the disk is missing. Windows closed the program LibreOffice because of this error.

Program: LibreOffice
File: 

The error value is listed in the Additional Data section.
User Action
1. Open the file again. This situation might be a temporary problem that corrects itself when the program runs again.
2. If the file still cannot be accessed and
	- It is on the network, your network administrator should verify that there is not a problem with the network and that the server can be contacted.
	- It is on a removable disk, for example, a floppy disk or CD-ROM, verify that the disk is fully inserted into the computer.
3. Check and repair the file system by running CHKDSK. To run CHKDSK, click Start, click Run, type CMD, and then click OK. At the command prompt, type CHKDSK /F, and then press ENTER.
4. If the problem persists, restore the file from a backup copy.
5. Determine whether other files on the same disk can be opened. If not, the disk might be damaged. If it is a hard disk, contact your administrator or computer hardware vendor for further assistance.

Additional Data
Error value: 00000000
Disk type: 0
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Application Error" />
    <EventID Qualifiers="49152">1005</EventID>
    <Version>0</Version>
    <Level>2</Level>
    <Task>100</Task>
    <Opcode>0</Opcode>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2021-09-10T17:47:04.9006771Z" />
    <EventRecordID>30874</EventRecordID>
    <Correlation />
    <Execution ProcessID="0" ThreadID="0" />
    <Channel>Application</Channel>
    <Computer>PC</Computer>
    <Security />
  </System>
  <EventData>
    <Data>
    </Data>
    <Data>LibreOffice</Data>
    <Data>00000000</Data>
    <Data>0</Data>
  </EventData>
</Event>
Comment 1 Roman Kuznetsov 2021-09-11 13:02:56 UTC
Please show us info from files by address

C:\Users\<user_name>\AppData\Roaming\LibreOffice\4\cache\

skia.log 

and 

opengl_device.log

Make sure you have latest driver for your videocard (check it on AMD's site)
Comment 2 jmah 2021-09-11 19:23:04 UTC
When I did my tests, the GPU driver was Catalyst 15.11.  I assume that I got this from Windows Update because I do not have the driver install file for this version.

  Driver Version:             15.201.1151.1008 (Catalyst 15.11)
  AMD Driver Package Version: 15.201.1151.1008-151104a-296217E
  Driver Date:                03-Nov-2015

I downloaded the latest stable GPU driver from AMD, which was Catalyst 15.7.1.  It is an older driver than what I originally had.

  Driver Version:              15.200.1062.1004 (Catalyst 15.7.1)
  AMD Driver Package Version:  15.20.1062.1004-150803a1-187674C
  AMD Catalyst Driver Version: 15.7.1
  Driver Date:                 02-Aug-2015

With Catalyst 5.7.1, I repeated scenarios 1 to 4 and got the same results.  The log files were also the same (except for the driver info) for both driver versions.

For scenario 1 (clean install of 7.1.6.2, LibreOffice did not start), the only file in the cache folder was skia.log.  This log only had the following two lines:

  RenderMethod: raster
  Compiler: Clang

For scenario 3 (Skia disabled, upgrade to 7.1.6.2, LibreOffice started), the skia.log file did not exist.  The opengl_device.log contained the following lines:

  DriverVersion: 15.200.1062.1004
  DriverDate: 8-3-2015
  DeviceID: PCI\VEN_1002&DEV_6898&SUBSYS_03461043&REV_00
  AdapterVendorID: 0x1002
  AdapterDeviceID: 0x6898
  AdapterSubsysID: 0x03461043
  DeviceKey: System\CurrentControlSet\Control\Video\{EBB2790B-2450-11EB-B421-806E6F6E6963}\0000
  DeviceString: AMD Radeon HD 5800 Series

For some reason, Windows Update does not offer any update to my GPU driver.  So I am stuck with Catalyst 5.7.1.
Comment 3 jmah 2021-09-11 19:25:09 UTC
Created attachment 174978 [details]
skia.log - LibreOffice 7.1.6.2 does not start.
Comment 4 jmah 2021-09-11 19:28:03 UTC
Created attachment 174979 [details]
opengl_device.log - LibreOffice 7.1.6.2 starts.
Comment 5 jmah 2021-09-11 19:31:11 UTC
Repeated scenarios 2 and 3 on a 5.5 year old laptop.  Same results.

  CPU: Intel Pentium N3540 (4 core, 4 threads)
  Memory: 8 GB
  GPU: Integrated Intel HD Graphics Gen7 4EU (Valleyfield)
  OS:  Microsoft Windows 10 Home (x64) Build 19042.1165 (20H2)
Comment 6 QA Administrators 2021-09-12 03:49:39 UTC Comment hidden (obsolete)
Comment 7 Ming Hua 2021-09-12 04:42:20 UTC
(In reply to jmah from comment #2)
> For some reason, Windows Update does not offer any update to my GPU driver. 
> So I am stuck with Catalyst 5.7.1.
Thanks for testing with the 5.7.1 driver.  Just FYI, it seems AMD still considers the 5.11 version beta status, and it offers 5.11.1 as the latest beta for download:
https://www.amd.com/en/support/kb/release-notes/rn-rad-win-15-11-1-beta

Note this is slightly different from what you had (5.11.1 vs. 5.11, driver version 15.201.1151.1010 vs. 15.201.1151.1008), so be cautious.
Comment 8 JO3EMC 2021-09-12 14:02:22 UTC
I don't know the technical details, but is it related to Bug 143152 too ?
Also UNCONFIRMED, currently.

The behavior is slightly different depending on the version.
This issue is occurring on LibreOffice Dev 7.3.
It does not occur in my environment on 7.2.0 or 7.1.5.
(I haven't tried it in 7.1.6 yet.)
It seems that the processor is AMD in common.
Comment 9 wikolas 2021-09-12 14:47:05 UTC
Hi @JO3EM
Indeed. It is probably linked. 
On my side, I have the issue too. Same work-around (uncheck skia)
7.1.5 was working well. 7.1.6 is faling. I did not checked other version.
I have also an older graphic card AMD ATI Radeon 4600. But CPU is Intel Core i5
Comment 10 JO3EMC 2021-09-12 16:09:55 UTC
Hi wikolas. Thank you for your new knowledge.
But confusingly ...
It did not reproduce in 7.1.6 on my environment.

Version: 7.1.6.2 (x64) / LibreOffice Community
Build ID: 0e133318fcee89abacd6a7d077e292f1145735c3
CPU threads: 8; OS: Windows 10.0 Build 19042; UI render: Skia/Vulkan; VCL: win
Locale: ja-JP (ja_JP); UI: ja-JP
Calc: CL

I don't know but is it because of the different version of the graphic driver...?
Comment 11 JO3EMC 2021-09-13 19:43:46 UTC
wikolas:
If you can reproduce Scenario 1-4 of Description, how about promote the Status of this report from UNCONFIRMED to NEW?

jmah and wikolas:
Why not give it a try to see if the latest development version of the 7.1 series (LibreOffice Dev 7.1.7) has improved the situation?
https://dev-builds.libreoffice.org/daily/libreoffice-7-1/Win-x86_64@tb77-TDF/

Bug 143152 introduced in Comment 8 has been resolved in the September 1st edition of LibreOfficeDev 7.3.0.0a0.
Comment 12 JO3EMC 2021-09-14 04:47:14 UTC
Details are unknown, but information that LibreOffice Dev 7.1.7 resolved the issue has been added to the Japanese Ask category.
https://ask.libreoffice.org/t/7-1-6-2/68048/5

Also, Bug 144174 regarding 7.2.1.1 has been reported to be resolved in 7.2.1.2.
Comment 13 amersdorfer 2021-09-14 14:23:18 UTC
Can confirm the crash of module C:\Program Files\LibreOffice\program\skialo.dll

Version: 7.1.6.2 (x64) / LibreOffice Community
Build ID: 0e133318fcee89abacd6a7d077e292f1145735c3
CPU threads: 2; OS: Windows 10.0 Build 19043; UI render: default; VCL: win
Locale: de-AT (de_AT); UI: de-DE
Calc: threaded

CPU: Intel Core 2 Duo T6350
ATI HD 4300 Series (Laptop)

Tested with the latest version as of today from
https://dev-builds.libreoffice.org/daily/libreoffice-7-1/Win-x86_64@tb77-TDF/
This works fine.
Comment 14 jmah 2021-09-14 18:25:54 UTC
JO3EMC:

Repeated scenarios 1 to 4 with 7.1.7.0.0 (2021-09-13 build).  LibreOffice starts properly in all cases.  Tried disabling/enabling Skia repeatly.  No problems.

Repeated with my Intel laptop (see comment 5 for specs).  LibreOffice starts properly in all cases.

  Version: 7.1.7.0.0+ (x64) / LibreOffice Community
  Build ID: e6b70cde3a34bcdbf200d3b9fb53cfdc9bef4f22
  CPU threads: 6; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
  Locale: en-CA (en_CA); UI: en-US
  Calc: CL

Note: For scenarios 2 to 4, I needed to rename the following folder to LibreOfficeDev to ensure that the configuration (e.g. Skia) was preserved when updating 7.1.5.2 to 7.1.7.0.0.

  C:\Users\<user>\AppData\Roaming\LibreOffice
Comment 15 wikolas 2021-09-14 19:13:15 UTC
So do I. 
I checked https://dev-builds.libreoffice.org/daily/libreoffice-7-1/Win-x86_64@tb77-TDF/2021-09-14_08.31.38/ and it worked well :-)
Very good !
Comment 16 Roman Kuznetsov 2021-09-14 19:28:17 UTC
So, let's close this one as WFM. Thank you all for testing
Comment 17 Mike Kaganski 2021-09-20 08:23:53 UTC

*** This bug has been marked as a duplicate of bug 144598 ***
Comment 18 Marco Gaiarin 2021-10-14 09:34:54 UTC
We are hitting the same trouble, but with a nvidia graphics.

Nome registro: Application
Origine:       Application Error
Data:          14/10/2021 11:20:18
ID evento:     1000
Categoria attività:(100)
Livello:       Errore
Parole chiave: Classico
Utente:        N/D
Computer:      CIP.ad.fvg.lnf.it
Descrizione:
Nome dell'applicazione che ha generato l'errore: soffice.bin, versione: 7.1.6.2, timestamp: 0x6135e2a5
Nome del modulo che ha generato l'errore: skialo.dll, versione: 7.1.6.2, timestamp: 0x61353cf8
Codice eccezione: 0xc000001d
Offset errore 0x000000000052b9c0
ID processo che ha generato l'errore: 0x1030
Ora di avvio dell'applicazione che ha generato l'errore: 0x01d7c0dcb05a500d
Percorso dell'applicazione che ha generato l'errore: C:\Program Files\LibreOffice\program\soffice.bin
Percorso del modulo che ha generato l'errore: C:\Program Files\LibreOffice\program\skialo.dll
ID segnalazione: f1f39ccc-2ccf-11ec-b489-78acc0ad2518
XML evento:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Application Error" />
    <EventID Qualifiers="0">1000</EventID>
    <Level>2</Level>
    <Task>100</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2021-10-14T09:20:18.000000000Z" />
    <EventRecordID>92189</EventRecordID>
    <Channel>Application</Channel>
    <Computer>CIP.ad.fvg.lnf.it</Computer>
    <Security />
  </System>
  <EventData>
    <Data>soffice.bin</Data>
    <Data>7.1.6.2</Data>
    <Data>6135e2a5</Data>
    <Data>skialo.dll</Data>
    <Data>7.1.6.2</Data>
    <Data>61353cf8</Data>
    <Data>c000001d</Data>
    <Data>000000000052b9c0</Data>
    <Data>1030</Data>
    <Data>01d7c0dcb05a500d</Data>
    <Data>C:\Program Files\LibreOffice\program\soffice.bin</Data>
    <Data>C:\Program Files\LibreOffice\program\skialo.dll</Data>
    <Data>f1f39ccc-2ccf-11ec-b489-78acc0ad2518</Data>
  </EventData>
</Event>

NVidia Quadro 600, driver version 21.21.13.7783, Windows 7 64bit.