Bug 144443 - Liberation fonts downgraded to 2.00.3 after LibreOffice 7.2 is installed
Summary: Liberation fonts downgraded to 2.00.3 after LibreOffice 7.2 is installed
Status: RESOLVED DUPLICATE of bug 144523
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
7.2.0.4 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Installer-Windows Fonts-Bundled
  Show dependency treegraph
 
Reported: 2021-09-11 15:03 UTC by Volga
Modified: 2021-09-27 07:46 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Liberation fonts showing file versions in MSI for 7.2.0 (37.54 KB, image/png)
2021-09-11 19:07 UTC, Mike Kaganski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Volga 2021-09-11 15:03:38 UTC
Description:
I've downloaded and install the Liberation fonts 2.1.4. But after I installed LibreOffice 7.2, all of them were backed to 2.00.3.

Steps to Reproduce:
1. Download Liberation fonts 2.1.4 from GitHub
2. Extract all of fonts from package 
3. Right click these font files, then click Install for All Users from context menu
4. Install LibreOffice 7.2

Actual Results:
All Liberation fonts in the system reverted to 2.00.3 release after installation. Open the MSI package with 7-Zip, I can found all Liberation fonts were still stay in 2.00.3 release.

Expected Results:
The MSI package shouldn't affect newer version of the Liberation fonts, and all  these fonts included in the MSI package should also updated to the latest version.


Reproducible: Always


User Profile Reset: No



Additional Info:
Liberation fonts releases could be available at the following resources:
https://github.com/liberationfonts/liberation-fonts/releases

LibreOffice release:
Version: 7.2.0.4 (x64) / LibreOffice Community
Build ID: 9a9c6381e3f7a62afc1329bd359cc48accb6435b
CPU threads: 4; OS: Windows 10.0 Build 19043; UI render: Skia/Raster; VCL: win
Locale: zh-CN (zh_CN); UI: zh-CN
Calc: threaded
Comment 1 Volga 2021-09-11 15:17:02 UTC
Liberation Sans Narrow is available at separate repo:
https://github.com/liberationfonts/liberation-sans-narrow/releases
Comment 2 Roman Kuznetsov 2021-09-11 18:34:13 UTC
Mike, should we update the fonts in LibreOffice distribution or may be the installer should check already installed fonts and if there are the fonts in OS LibreOffice shouldn't downgrade it to previous version?
Comment 3 Mike Kaganski 2021-09-11 19:07:14 UTC
Created attachment 174977 [details]
Liberation fonts showing file versions in MSI for 7.2.0

(In reply to Roman Kuznetsov from comment #2)
> Mike, should we update the fonts in LibreOffice distribution

No idea; I don't track updates of fonts.

> or may be the installer should check already installed fonts and if there
> are the fonts in OS LibreOffice shouldn't downgrade it to previous version?

Sure. And we already made sure to include font versions to the installer metadata (bug 116581). And they are indeed in the package.

I didn't try to repro myself; but I suspect that MS does something strange when installing fonts for all, which doesn't allow to detect version downgrade.

At any case, a full install log is required, as with any installer issue; the procedure is described at [1].

I don't really think we may (or should) do anything if that's some MS bug.

[1] https://wiki.documentfoundation.org/Faq/General/General_Installation_Issues_(Windows#Create_an_installation_log
Comment 4 Volga 2021-09-15 08:46:02 UTC
Unfortunately, it was happened again to me with the following release
Version: 7.2.1.2 (x64) / LibreOffice Community
Build ID: 87b77fad49947c1441b67c559c339af8f3517e22
CPU threads: 4; OS: Windows 10.0 Build 19043; UI render: Skia/Raster; VCL: win
Locale: zh-CN (zh_CN); UI: zh-CN
Calc: threaded

(In reply to Mike Kaganski from comment #3)
> No idea; I don't track updates of fonts.

Mike, I think it's reasonable to update the fonts, since their developer made some series of bug fixes in responce of feedbacks from GitHub and other outside issue trackers.
Comment 5 Mike Kaganski 2021-09-15 08:46:53 UTC
(In reply to Volga from comment #4)

Shrug; patches welcome.
Comment 6 Mike Kaganski 2021-09-15 08:58:03 UTC
(In reply to Mike Kaganski from comment #5)
> (In reply to Volga from comment #4)

In fact, first thing is to file a separate request. When I wrote that I don't track font updates, I intended to express that personally I'm not interested in "update fonts" topic; possibly we have people who are. But in any case, a request to update is orthogonal to the installer issue - whether it's our problem, or on MS side (and there's still no full log that you created installing 7.2.1.2 to clarify that).
Comment 7 Volga 2021-09-16 02:40:57 UTC
OK. To update these fonts, see bug 144523.
Comment 8 Volga 2021-09-21 08:39:26 UTC
(In reply to Volga from comment #4)
> Mike, I think it's reasonable to update the fonts, since their developer
> made some series of bug fixes in responce of feedbacks from GitHub and other
> outside issue trackers.

I made a mistake, sorry, I found I've already proposed this update once at my bug list. Althrough the fonts was already updated last week, I think there is necessary to build a bulletin to track any changes for the dependencies, including libraries and fonts, once their developers made a new release, we could be noticed soon, and attempt to apply into future version of LibreOffice.
Comment 9 Xisco Faulí 2021-09-22 11:24:38 UTC
The font has been updated in LibreOffice 7.2 as well. See https://gerrit.libreoffice.org/c/core/+/122129
it will be available in LibreOffice 7.2.2
Closing as dupe of bug 144523

*** This bug has been marked as a duplicate of bug 144523 ***
Comment 10 Adolfo Jayme Barrientos 2021-09-27 07:46:41 UTC
(In reply to Volga from comment #8)
> I think there is necessary to build a bulletin to track any changes for the
> dependencies, including libraries and fonts, once their developers made a
> new release, we could be noticed soon, and attempt to apply into future
> version of LibreOffice.

Several solutions exist for dependency tracking. Investigating which one we could integrate could be a work item for a member of the Engineering Steering Comittee.