Bug 144458 - Can't change character (font) color (except once to "dark red 2")
Summary: Can't change character (font) color (except once to "dark red 2")
Status: RESOLVED DUPLICATE of bug 144037
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.1.2.1 rc
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2021-09-12 17:40 UTC by Marco Menardi
Modified: 2021-09-14 06:08 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screencast showing the bug (659.57 KB, application/octet-stream)
2021-09-12 19:37 UTC, Marco Menardi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marco Menardi 2021-09-12 17:40:06 UTC
Description:
It's a regression, works with i.e. 7.2.0.4.
You click the "font color" toolbar and try to pick a color like i.e. green or yellow, does not work, it you type the text color remains the same.
If you instead choose the toolbar default "dark red 2" then it works, but you can't go to any other color (i.e. go back to black / automatic).
You can't change color also with Format -> Character -> [Font effects] and Font color property.

Steps to Reproduce:
1. create a new writer document
2. write something (blabla bla bla blablabla)
3. select it and drop down the color selection using the "Font color" toolbar
4. try to select a color different than "dark red 2", document text color does not change

Actual Results:
text remains of the same color or changes to "dark red 2"

Expected Results:
text should change color


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
I've tested also in a Kubuntu 21.10 VM. It had LiBo 7.2.0.4 and everything was ok. Then I upgraded and 7.2.1.rc2 was installed, that has this bug
Comment 1 Caolán McNamara 2021-09-12 18:27:43 UTC
What does it say in help about for user interface ?, i.e. is this a kf5 build specific issue ?
Comment 2 Marco Menardi 2021-09-12 19:26:18 UTC
Version: 7.2.1.2 / LibreOffice Community
Build ID: 20(Build:2)
CPU threads: 6; OS: Linux 5.13; UI render: default; VCL: kf5 (cairo+xcb)
Locale: it-IT (it_IT.UTF-8); UI: it-IT
Ubuntu package version: 1:7.2.1~rc2-0ubuntu1
Calc: threaded
Comment 3 Marco Menardi 2021-09-12 19:33:17 UTC
I've just noticed that also the tool bar "Character highlight color" has the same behavior, you can select only the default (yellow) background.
I'll add a screencast to show exactly what happens (and did not with 7.2.0.4, same PC)
Comment 4 Marco Menardi 2021-09-12 19:37:25 UTC
Created attachment 174990 [details]
Screencast showing the bug
Comment 5 Michael Weghorn 2021-09-14 06:08:06 UTC
That sounds like bug 144037 (s.a. description in bug 143788 which mentions the color picker scenario, too).

This has been fixed in LibreOffice 7.2.2.

*** This bug has been marked as a duplicate of bug 144037 ***