Bug 144485 - Regression: Cannot set line color in LibO 7.2 with KF5 VCL
Summary: Regression: Cannot set line color in LibO 7.2 with KF5 VCL
Status: RESOLVED DUPLICATE of bug 144037
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.2.1.1 rc
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2021-09-14 08:54 UTC by Callegar
Modified: 2021-09-20 05:58 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Callegar 2021-09-14 08:54:32 UTC
Description:
It is impossible to set the line color in LibO 7.2.  When the dialog opens, trying to change the color in line properties, opens the color selection sub-window, but when you select a color, the line color is not updated.

This makes draw 7.2 substantially usable only as a viewer.

Steps to Reproduce:
1. Open libreoffice --draw
2. Get the styles panel
3. Select the default drawing style and pick the "modify" option
4. Go to the "Line" tab in the Graphic style window
5. Try to change the line color

Actual Results:
The color does not get updated

Expected Results:
The color should change into the selected one as it used to do in all previous versions of LibO.


Reproducible: Always


User Profile Reset: No



Additional Info:
/
Comment 1 Xisco Faulí 2021-09-14 14:00:50 UTC
I can't reproduce it in

Version: 7.3.0.0.alpha0+ / LibreOffice Community
Build ID: e7a40c0ded1ba26b6b8f3da5a0b894e9c7ee7a96
CPU threads: 4; OS: Linux 5.10; UI render: default; VCL: x11
Locale: de-DE (en_US.UTF-8); UI: en-US
Calc: threaded

nor with GTK3

To be certain the reported issue is not related to corruption in the user profile, could you please reset your Libreoffice profile ( https://wiki.documentfoundation.org/UserProfile ) and re-test?

I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the issue is still present
Comment 2 Callegar 2021-09-14 14:21:46 UTC
Double checked. Again a KF5 issue. Sorry for not checking with a different VCL earlier.
Comment 3 David 2021-09-14 23:56:51 UTC
This is probably the same UI issue as bug 144499.  All dropdown boxes are affected.  Happens with a new profile.
Comment 4 Callegar 2021-09-15 00:20:47 UTC
Incidentally, is there a tracking bug to collect as dependencies the items where the KF5 VCL has issues wrt the GTK3 one? Is 102495 still relevant? Should this issue land there? I have some other KF5 bugs open that should probably go there if it is still used...
Comment 5 Jan-Marek Glogowski 2021-09-15 12:15:00 UTC

*** This bug has been marked as a duplicate of bug 144037 ***
Comment 6 Michael Weghorn 2021-09-20 05:58:13 UTC
(In reply to sergio.callegari from comment #4)
> Incidentally, is there a tracking bug to collect as dependencies the items
> where the KF5 VCL has issues wrt the GTK3 one? Is 102495 still relevant?
> Should this issue land there? I have some other KF5 bugs open that should
> probably go there if it is still used...

Yes, bug 102495 is still used to track kf5-specific issues.