Bug 144491 - CRASH - mailmerge in Writer with Base using MariaDB
Summary: CRASH - mailmerge in Writer with Base using MariaDB
Status: RESOLVED DUPLICATE of bug 144564
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.2.0.4 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-09-14 13:36 UTC by AndreaM
Modified: 2021-09-29 09:01 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
text file (126.42 KB, application/octet-stream)
2021-09-14 13:40 UTC, AndreaM
Details

Note You need to log in before you can comment on or make changes to this bug.
Description AndreaM 2021-09-14 13:36:25 UTC
Description:
When launch a print of LiOwriter doc linked a registrated DB (MariaDB) LiOwriter crashes; it appened whit 7.2(x64) version instead winth 7.0.6.2 (x64) version it works

Steps to Reproduce:
1.Register DB type:MariaDB in localhost
2.create a odt with camps of a query
3.try array print

Actual Results:
crash

Expected Results:
the window open and I can select a record of query to print


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
The softaware Version: 7.2.0.4 (x64) / LibreOffice Community Build ID: 9a9c6381e3f7a62afc1329bd359cc48accb6435b  CPU threads: 2; OS: Windows 10.0 Build 19043; UI render: default; VCL: win  Locale: it-IT (it_IT); UI: it-IT Calc: threaded
CRASH, instead the 7.0.6.2 (x64) version it works
Comment 1 AndreaM 2021-09-14 13:40:27 UTC
Created attachment 175020 [details]
text file
Comment 2 Alex Thurgood 2021-09-15 11:00:50 UTC
@Andrea : please explain what you mean by array print - do you  mean mailmerge ?
Comment 3 Alex Thurgood 2021-09-15 11:05:27 UTC
Unfortunately, I can't read the dump file.
Comment 4 AndreaM 2021-09-15 15:07:51 UTC
(In reply to Alex Thurgood from comment #2)
> @Andrea : please explain what you mean by array print - do you  mean
> mailmerge ?

Yes, mailmerge
Comment 5 Alex Thurgood 2021-09-15 15:31:18 UTC
Sounds like a DUPLICATE of bug 144461
Comment 6 AndreaM 2021-09-18 08:40:32 UTC
I don't think it is like a DUPLICATE of bug 144461:

I tried to run the last version and it still doesn't work

This is the crash report:

https://crashreport.libreoffice.org/stats/crash_details/ecdfa722-ae0d-4409-8931-758e236360ad#allthreads

Version 7.0.6.2 x64, on the other hand, works correctl, why?
Comment 7 AndreaM 2021-09-20 13:51:25 UTC
the Version: 7.1.6.2 also has the same problem

https://crashreport.libreoffice.org/stats/crash_details/09b2f1cf-f0cc-4790-8025-8722c59edfcf
Comment 8 AndreaM 2021-09-20 15:18:44 UTC
Then I reinstalled the version 7.0.6.2 x64 because it is the last one that works.
Comment 9 Xisco Faulí 2021-09-29 09:01:58 UTC
Hello AndreaM,
It looks like a duplicate of bug 144564

Could you please try to reproduce it with a master build from
http://dev-builds.libreoffice.org/daily/master/ ?
You can install it alongside the standard version.

*** This bug has been marked as a duplicate of bug 144564 ***