Bug 144523 - Update Liberation fonts to 2.1.4 release
Summary: Update Liberation fonts to 2.1.4 release
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
7.2.1.1 rc
Hardware: All All
: medium normal
Assignee: Heiko Tietze
URL:
Whiteboard: target:7.3.0 target:7.2.2
Keywords:
: 144443 (view as bug list)
Depends on:
Blocks: Fonts-Bundled
  Show dependency treegraph
 
Reported: 2021-09-16 02:40 UTC by Volga
Modified: 2021-09-22 11:24 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Volga 2021-09-16 02:40:41 UTC
Description:
The Liberation fonts is now developed at GitHub, and having numerous bug fixes, the latest version is 2.1.4. However the LibreOffice is still bundled 2.00.3 release.

Steps to Reproduce:
1. Open the MSI package with 7-zip
2. Extract the fonts

Actual Results:
Open the font files you can see the fonts are still 2.00.3 version.

Expected Results:
-


Reproducible: Always


User Profile Reset: No



Additional Info:
Liberation fonts release pages at GitHub
https://github.com/liberationfonts/liberation-fonts/releases
https://github.com/liberationfonts/liberation-sans-narrow/releases

Version: 7.2.1.2 (x64) / LibreOffice Community
Build ID: 87b77fad49947c1441b67c559c339af8f3517e22
CPU threads: 4; OS: Windows 10.0 Build 19043; UI render: Skia/Raster; VCL: win
Locale: zh-CN (zh_CN); UI: zh-CN
Calc: threaded
Comment 1 Heiko Tietze 2021-09-16 08:36:45 UTC
Liberation Narrow is still 1.07.6.
Comment 2 Commit Notification 2021-09-16 10:07:08 UTC
Heiko Tietze committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/95406f2e172df13ae9c6536ca1378cd7fca3b2de

Resolves tdf#144523 - Update Liberation fonts to 2.1.4 release

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Commit Notification 2021-09-17 03:12:01 UTC
Heiko Tietze committed a patch related to this issue.
It has been pushed to "libreoffice-7-2":

https://git.libreoffice.org/core/commit/299da25441aea14e631888d1f355cd6b0ecd6d7d

Resolves tdf#144523 - Update Liberation fonts to 2.1.4 release

It will be available in 7.2.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Xisco Faulí 2021-09-22 11:24:38 UTC
*** Bug 144443 has been marked as a duplicate of this bug. ***