Bug 144562 - Many UI elements (list box, drop down) don't work at all in kf5 environment
Summary: Many UI elements (list box, drop down) don't work at all in kf5 environment
Status: RESOLVED DUPLICATE of bug 144037
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.2.1.1 rc
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2021-09-17 03:10 UTC by Rizal Muttaqin
Modified: 2021-09-17 06:54 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rizal Muttaqin 2021-09-17 03:10:52 UTC
This is so critical bug. I have found similar issue in 7.3 (alpha) daily master build and did not expect it will appears in 7.2.1 release. 

Step to reproduce:
1. Open up Writer
2. Insert table from standard toolbar > nothing inserted
3. Insert table from Table > Insert Table > click OK > nothing inserted
4. Try change icon theme: Tools > Options > LibreOffice > View > change icon theme > the selected theme can not be selected

The issue affected drop down and list box UI. Even changing font and size from drop down does not work. Please patch it as soon as possible

In kf5, even they do not work in safe mode.

This bug just affect kf5 environment. GTK3 and gen are fine

Version: 7.2.1.2 / LibreOffice Community
Build ID: 87b77fad49947c1441b67c559c339af8f3517e22
CPU threads: 4; OS: Linux 5.11; UI render: default; VCL: kf5 (cairo+xcb)
Locale: id-ID (id_ID.UTF-8); UI: id-ID
Calc: threaded

Operating System: KDE neon 5.22
KDE Plasma Version: 5.22.5
KDE Frameworks Version: 5.86.0
Qt Version: 5.15.3
Kernel Version: 5.11.0-34-generic (64-bit)
Graphics Platform: X11
Processors: 4 × Intel® Core™ i3-6006U CPU @ 2.00GHz
Memory: 7.7 GiB of RAM
Graphics Processor: Mesa Intel® HD Graphics 520
Comment 1 Stéphane Guillou (stragu) 2021-09-17 06:06:32 UTC
Assumed to be Linux-only (I don't think kf5 can be used anywhere else?)
Comment 2 Buovjaga 2021-09-17 06:54:45 UTC
Sadly it missed 7.2.1.

*** This bug has been marked as a duplicate of bug 144037 ***