Bug 144585 - button popups don't open with KF5 VCL on Wayland
Summary: button popups don't open with KF5 VCL on Wayland
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.3.0.0.alpha1+
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.2.2 target:7.4.0 target:7.3.3
Keywords: bibisectNotNeeded, regression
: 144993 146942 147172 147534 147745 147777 147832 147888 147957 148222 148562 148765 (view as bug list)
Depends on:
Blocks: Wayland KDE
  Show dependency treegraph
 
Reported: 2021-09-18 10:46 UTC by Antonio Rojas
Modified: 2022-05-17 08:06 UTC (History)
26 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Antonio Rojas 2021-09-18 10:46:40 UTC
Description:
In 7.2.1, and using the KF5 VCL on Wayland, button popus don't open (or rather close immediately, making them unusable).

Like bug 144037, this is a regression from 9dcf5816c90e9819861332f11e014ef7b78e2fe7, but a1a83b6b3b4459de353e0cdc8cdf402370c0a5c4 does NOT fix this.

Steps to Reproduce:
1.Open Writer on Wayland with the KF5 VCL
2. Try to insert a table via the toolbar button

Actual Results:
Button popup disappears

Expected Results:
Button popup opens and can be used


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Version: 7.2.1.2 / LibreOffice Community
Build ID: 20(Build:2)
CPU threads: 8; OS: Linux 5.14; UI render: default; VCL: kf5 (cairo+wayland)
Locale: es-ES (es_ES.UTF-8); UI: es-ES
7.2.1-2
Calc: threaded
Comment 1 Buovjaga 2021-09-18 17:13:32 UTC
Yeah, they are rather wonky: they do open upon the second click, but are not placed below their parent element.

Arch Linux 64-bit
Version: 7.3.0.0.alpha0+ / LibreOffice Community
Build ID: 88a6ac9f75a4375b72111af5a3e004bef4226455
CPU threads: 8; OS: Linux 5.14; UI render: default; VCL: kf5 (cairo+wayland)
Locale: fi-FI (fi_FI.UTF-8); UI: en-US
Calc: threaded
Built on 15 September 2021
Comment 2 Antonio Rojas 2021-09-19 10:48:54 UTC
In kwin it doesn't open at all, no matter how many times I click.
Comment 3 Buovjaga 2021-09-19 15:42:30 UTC
(In reply to Antonio Rojas from comment #2)
> In kwin it doesn't open at all, no matter how many times I click.

It does for me, just not for you.
Comment 4 Michael Weghorn 2021-09-21 12:27:01 UTC
(In reply to Buovjaga from comment #1)
> Yeah, they are rather wonky: they do open upon the second click, but are not
> placed below their parent element.

That's what I get as well w/ current master in a Plasma Wayland session on Debian testing (plasma-desktop 4:5.21.5-2, kwin-wayland   4:5.21.5-2).
Comment 5 Commit Notification 2021-09-25 12:59:44 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "libreoffice-7-2":

https://git.libreoffice.org/core/commit/a928bab9fb68ff8fe45aca212b3c794799db31f6

tdf#144585 Qt5 restore old VCL popup handling

It will be available in 7.2.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Michael Weghorn 2021-09-25 13:19:45 UTC
Fixed by reverting the involved commits on the 7-2 branch for now. Let's leave this bug report open until there's a fix on the master branch, too.
Comment 7 Commit Notification 2021-09-26 17:48:26 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "libreoffice-7-2-2":

https://git.libreoffice.org/core/commit/dac5a26ae1108d9ad29e09a800601247fe8c50d6

tdf#144585 Qt5 restore old VCL popup handling

It will be available in 7.2.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Michael Weghorn 2021-10-12 10:01:58 UTC
This is fixed in the 7-2 branch, but issue still exists on master (Wayland-only). Reopening the ticket, s.a. discussion in tdf#144037.

@Jan-Marek: Do you think it makes sense to revert the corresponding commits for master as well for now, until a better solution has been found?
Comment 9 Michael Weghorn 2021-10-12 10:16:03 UTC
*** Bug 144993 has been marked as a duplicate of this bug. ***
Comment 10 Michael Weghorn 2022-01-25 06:18:30 UTC
*** Bug 146942 has been marked as a duplicate of this bug. ***
Comment 11 Ed Tomlinson 2022-02-10 15:01:31 UTC
With kde plasma 5.24 and libre office 7.3.0.3 (up to date arch install) this is still happening.  It is the only shows topper bug I have encountered here when using kde & wayland (with any application).
Comment 12 Bob Wong 2022-02-17 03:20:57 UTC
Same problem using Debian kde 5.23.5 with wayland. My libreoffice version is 7.3.1. A temporary solution is to set the environment variable QT_QPA_PLATFORM=xcb before running libreoffice. So the command is QT_QPA_PLATFORM=xcb libreoffice. And this will make the program work just fine. Anyway hope the developer fix the issue soon.
Comment 13 Michael Weghorn 2022-02-17 06:19:02 UTC
*** Bug 147172 has been marked as a duplicate of this bug. ***
Comment 14 Buovjaga 2022-02-19 10:54:11 UTC
*** Bug 147534 has been marked as a duplicate of this bug. ***
Comment 15 mir.einer 2022-02-19 12:02:54 UTC
The same problem here on Arch Linux with KDE Plasma 5.2.4 Wayland session. Since libreOffice-fresh version 7.3.x the drop-down list controls doesn't respond to mouse or keyboard input (list doesn't drop down).
Libreoffice-still version 7.2.3 the drop-down list controls work, but this older version got the tiny toolbar problem.
Comment 16 GeneC 2022-02-19 21:57:48 UTC
Confirm issue on Arch using Wayland.

Xcb is a not great workaround;  at least for me on 4k monitor, it looks pretty icky. Fonts render quite poorly.

Packages provided by Arch repo:

Version: 7.3.0.3 / LibreOffice Community
Build ID: 30(Build:3)
CPU threads: 8; OS: Linux 5.17; UI render: default; VCL: kf5 (cairo+wayland)
Locale: en-US (en_US.UTF-8); UI: en-US
7.3.0-5
Calc: threaded

qt5-base 5.15.2+kde+r301-1
lasma-desktop 5.24.1-1
Comment 17 shenlebantongying 2022-03-02 22:28:47 UTC
Can confirm still exist in

Version: 7.3.0.3 / LibreOffice Community
Build ID: 30(Build:3)
CPU threads: 8; OS: Linux 5.16; UI render: default; VCL: kf5 (cairo+wayland)
Locale: en-CA (en_CA.UTF-8); UI: en-US
7.3.0-6
Calc: threaded
Comment 18 giors_00 2022-03-03 09:00:08 UTC
Same on 

Version: 7.3.0.3 / LibreOffice Community
Build ID: 30(Build:3)
CPU threads: 4; OS: Linux 5.16; UI render: default; VCL: kf5 (cairo+wayland)
Locale: es-ES (es_ES.UTF-8); UI: es-ES
7.3.0-7
Calc: threaded
Comment 19 Buovjaga 2022-03-03 15:05:14 UTC
*** Bug 147745 has been marked as a duplicate of this bug. ***
Comment 20 Michael Weghorn 2022-03-04 07:30:39 UTC
(In reply to GeneC from comment #16)
> Xcb is a not great workaround;  at least for me on 4k monitor, it looks
> pretty icky. Fonts render quite poorly.

Another option is to use the more mature gtk3 VCL plugin by setting environment variable SAL_USE_VCLPLUGIN=gtk3
Comment 21 GeneC 2022-03-05 12:33:20 UTC
Seems that  SAL_USE_VCLPLUGIN=gtk3 doesn't understand HiDpi (4k) monitor and creates very large window with giant fonts.

I tried using it together with GDK_DPI_SCALE=2.0 and SAL_FORCEDPI=200 but neither has any effect on the crazy large window.

Be nice if this menu bug could be fixed
Comment 22 Buovjaga 2022-03-13 09:35:13 UTC
*** Bug 147957 has been marked as a duplicate of this bug. ***
Comment 23 robby.engelmann 2022-03-14 13:35:47 UTC
*** Bug 147832 has been marked as a duplicate of this bug. ***
Comment 24 Michael Weghorn 2022-03-23 15:30:13 UTC
*** Bug 147888 has been marked as a duplicate of this bug. ***
Comment 25 Buovjaga 2022-03-28 06:20:15 UTC
*** Bug 148222 has been marked as a duplicate of this bug. ***
Comment 26 Michael Weghorn 2022-04-02 18:25:41 UTC
*** Bug 147172 has been marked as a duplicate of this bug. ***
Comment 27 Commit Notification 2022-04-06 07:52:46 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/fbf739198aa7f02975d531521c6525073783c7f1

tdf#144585 Qt fix Wayland LO fake popups

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 28 Commit Notification 2022-04-06 12:50:52 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "libreoffice-7-3":

https://git.libreoffice.org/core/commit/c309ddb6d9cd61f3024ffeee33fce1a0e173d9cc

tdf#144585 Qt fix Wayland LO fake popups

It will be available in 7.3.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 29 Michael Weghorn 2022-04-07 08:27:00 UTC
*** Bug 147777 has been marked as a duplicate of this bug. ***
Comment 30 Buovjaga 2022-04-07 10:19:35 UTC
Verified, thanks
Comment 31 GeneC 2022-04-07 11:46:49 UTC
confirm that the daily 7.3.3 is fixed.

thank you!
Comment 32 Michael Weghorn 2022-04-14 04:55:50 UTC
*** Bug 148562 has been marked as a duplicate of this bug. ***
Comment 33 hasezoey 2022-04-14 11:01:30 UTC
if i understand correctly, a fix has been but into place in master and should be in the daily builds, but i had tried (yesterday) a appimage named "LibreOfficeDev-7.4.0.0.alpha0_2022-01-23-x86_64.AppImage" which should have been based on the latest master, but the problem still occurred for me, the appimage is from https://libreoffice.soluzioniopen.com/daily-version/ (which i were linked to from https://www.libreoffice.org/download/appimage/ for daily appimage builds)

Appimage information:
Version: 7.4.0.0.alpha0+ / LibreOffice Community
Build ID: 465c3ad95059f0efa13c8027f7383c4d20a5b2ff
CPU threads: 8; OS: Linux 5.16; UI render: default; VCL: kf5 (cairo+wayland)
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 34 Buovjaga 2022-04-14 11:04:27 UTC
(In reply to hasezoey from comment #33)
> if i understand correctly, a fix has been but into place in master and
> should be in the daily builds, but i had tried (yesterday) a appimage named
> "LibreOfficeDev-7.4.0.0.alpha0_2022-01-23-x86_64.AppImage" which should have
> been based on the latest master, but the problem still occurred for me, the
> appimage is from https://libreoffice.soluzioniopen.com/daily-version/ (which
> i were linked to from https://www.libreoffice.org/download/appimage/ for
> daily appimage builds)

It's not based on the latest master, but from January as you can see from the date: 2022-01-23
Unfortunately the appimage guy has been busy, so has not updated the packages.
You can create your own ones: https://wiki.documentfoundation.org/Installing_in_parallel/Linux#Automated_installation
Comment 35 hasezoey 2022-04-14 11:07:11 UTC
> It's not based on the latest master, but from January as you can see from the date: 2022-01-23

oops, didnt check the actual file name, assumed that what was listed was actually the latest version based on the master branch (i guess i just checked the version), sorry for the confusion
Comment 36 Michael Weghorn 2022-05-16 06:32:15 UTC
*** Bug 148765 has been marked as a duplicate of this bug. ***
Comment 37 hasezoey 2022-05-16 14:14:57 UTC
can confirm that with the 7.3.3 version in manjaro the issue is fixed
Comment 38 fil7racket 2022-05-17 08:06:56 UTC
Confirmed that this fixed the issue on KDE Neon on Wayland of duplicated bug https://bugs.documentfoundation.org/show_bug.cgi?id=148765