Bug 144602 - Calc dropdown lists are unclickable (disappear)
Summary: Calc dropdown lists are unclickable (disappear)
Status: RESOLVED DUPLICATE of bug 144037
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.2.1.1 rc
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-09-19 12:56 UTC by Michael M
Modified: 2022-07-15 09:27 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael M 2021-09-19 12:56:50 UTC
Description:
Since 7.2 update dropdown lists in spreadsheet can not be clicked with a mouse (that might be a platform and window desktop environment issue). It happens with any dropdown list: autofilter, selection of a cell value from a pre-defined list, etc.

Steps to Reproduce:
1. Create new spreadsheet document with some data.
2. Set up autofilter.
3. Try to change autofilter state (try to click any checkbox).

To reproduce another reveal of the problem:
1. Select empty cell.
2. Set up input limits (Data > Check > Condition > Allow: list > fill in «Elements» field; some names may differ since I have another locale).
3. Try to fill in a cell within dropdownlist, clicking on any value.

Actual Results:
Dropdown list disappears, nothing else happens.

Expected Results:
Cell should change a value, checkbox in autofilter should change its state.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 7.2.1.2 / LibreOffice Community
Build ID: 20(Build:2)
CPU threads: 2; OS: Linux 5.4; UI render: default; VCL: kf5 (cairo+xcb)
Locale: ru-RU (ru_RU.UTF-8); UI: ru-RU
Ubuntu package version: 1:7.2.1~rc2-0ubuntu0.20.04.1~lo3
Calc: threaded
Window desktop environment: KDE 5.68 (plasma: 5.18.5, Qt: 5.12.8)
Comment 1 m.a.riosv 2021-09-19 13:39:56 UTC
I can't repro, please can you attach a sample file to test.
Version: 7.2.2.0.0+ (x64) / LibreOffice Community
Build ID: d51609fbe49042867fa734ef4f6c1755df8514a2
CPU threads: 4; OS: Windows 10.0 Build 21390; UI render: Skia/Vulkan; VCL: win
Locale: es-ES (es_ES); UI: en-US Calc: CL
Comment 2 Timur 2021-09-20 08:01:35 UTC
Probably duplicate of bug 144037.
Comment 3 Mehmet Rıza Saraç 2021-09-20 21:19:10 UTC
After update to 7.2.1.2 libreoffice community i have same issue with my linux installation (kubuntu 18.04 and kubuntu 20.04 on both desktop and laptop pc).

I can not left click on dropdown list to select any items, i need to point item by mouse then pres enter from keyboard to select. It also effect left click, when i try to left click on any dropdown list item without a succesful selection than move mouse cursor to system title bar then left click on it, the nearest cell is selected. 

Also using Data > Validity... 
On "criteria" tab changing "Allow" list from default value by left click is not available, only keyboard "enter" key works.
Comment 4 m.a.riosv 2021-09-21 20:34:48 UTC
Let's set as new.
Comment 5 Luis 2021-09-22 16:28:15 UTC
It happens to me too.
To solve it I had to do:
    
    apt remove libreoffice-kf5.
Comment 6 Mehmet Rıza Saraç 2021-09-22 20:12:50 UTC
Removing libreoffice-kf5 also removes libreoffice-kde, but without kde integration left click is working normally. I hope the issue will be solved, i got use to use with integration. But without left click, you can not use color palette either
Comment 7 Carsten Becker 2021-09-24 17:07:35 UTC
Affects me, too. It's also in the Sorting and Standard Filter dialogs. You can work around this by using your keyboard to select fields (tab, arrows & enter), but clicking doesn't work, and that's a major annoyance.

--
Version: 7.2.1.2 / LibreOffice Community
Build ID: 20(Build:2)
CPU threads: 4; OS: Linux 5.11; UI render: default; VCL: kf5 (cairo+xcb)
Locale: de-DE (de_DE.UTF-8); UI: de-DE
Ubuntu package version: 1:7.2.1~rc2-0ubuntu0.20.04.1~lo3
Calc: threaded

$ lsb_release -d
Description:    Ubuntu 20.04.3 LTS

libreoffice-kde5/focal,now 1:7.2.1~rc2-0ubuntu0.20.04.1~lo3 amd64  [installiert]
libreoffice-kf5/focal,now 1:7.2.1~rc2-0ubuntu0.20.04.1~lo3 amd64  [Installiert,automatisch]
libreoffice-plasma/focal,now 1:7.2.1~rc2-0ubuntu0.20.04.1~lo3 amd64  [Installiert,automatisch]
libreoffice-qt5/focal,now 1:7.2.1~rc2-0ubuntu0.20.04.1~lo3 amd64  [Installiert,automatisch]
Comment 8 Buovjaga 2021-09-27 08:06:00 UTC
Please test with 7.3
Comment 9 Mehmet Rıza Saraç 2021-09-29 15:35:12 UTC
With new updates the problem seems to be partially solved. 
Using version 7.2.1.2

Now i can use mouse pointer on color palette and drop down menus with kde integration. 

But there is still a problem with pointer behavior;
when i use pointer on a drop down list (not color palette or any other libre office program menus), pointer still seems to be locked on process, it looks like got locked in spread sheet window. 

After left click on drop down lists i need to click on an empty area in spread sheet grid area, otherwise left clicking on any place like sheet tabs or other areas on screen, nearest spreadsheet cell is being selected and a second left click work as normally. This problem also blocks mouse pointer when i use multiple computers with barrier and try to move around computers with mouse pointer while left click is blocked.

This problem doesn't occur when i open drop down list with "selection list" from right click menu rather than directly opening drop down list with mouse click.
Comment 10 QA Administrators 2022-03-29 03:59:52 UTC Comment hidden (obsolete)
Comment 11 Mehmet Rıza Saraç 2022-03-29 07:13:17 UTC Comment hidden (obsolete)
Comment 12 Mehmet Rıza Saraç 2022-03-29 15:09:58 UTC Comment hidden (obsolete)
Comment 13 Gabor Kelemen (allotropia) 2022-07-15 09:27:30 UTC
(In reply to Timur from comment #2)
> Probably duplicate of bug 144037.

Checked with SAL_USE_VCLPLUGIN=qt5 in bibisect-linux-7.2/7.3, indeed it is.

*** This bug has been marked as a duplicate of bug 144037 ***