Bug 144693 - Tip of the Day sticks on tip 24
Summary: Tip of the Day sticks on tip 24
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.2.1.1 rc
Hardware: x86-64 (AMD64) Windows (All)
: medium trivial
Assignee: Heiko Tietze
URL:
Whiteboard: target:7.3.0 target:7.2.3
Keywords:
Depends on:
Blocks: Tip-Of-The-Day
  Show dependency treegraph
 
Reported: 2021-09-24 06:23 UTC by Colin
Modified: 2021-10-08 08:21 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
screen dump (100.65 KB, image/png)
2021-09-30 12:59 UTC, Colin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Colin 2021-09-24 06:23:59 UTC
Version: 7.2.1.2 (x64) / LibreOffice Community
Build ID: 87b77fad49947c1441b67c559c339af8f3517e22
CPU threads: 4; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: sv-SE (en_GB); UI: en-GB
Calc: threaded
Tip of the day was intentionally left "active" following a recent update to 7.2.1.2
It never gets past tip 23.
I have no idea for how long this has been occurring as I usually turn them off.
I'm now curious as to what the remaining 200 tips contain ;)).

Also, the version selection box above stops with 7.2.1.1rc in this release series.
Comment 1 Xisco Faulí 2021-09-29 15:40:42 UTC
Not reproducible in

Version: 7.2.0.4 (x86) / LibreOffice Community
Build ID: 9a9c6381e3f7a62afc1329bd359cc48accb6435b
CPU threads: 2; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: default; VCL: win
Locale: es-ES (es_ES); UI: es-ES
Calc: threaded

To be certain the reported issue is not related to corruption in the user profile, could you please reset your Libreoffice profile ( https://wiki.documentfoundation.org/UserProfile ) and re-test?

I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the issue is still present
Comment 2 Colin 2021-09-29 16:57:02 UTC
(In reply to Xisco Faulí from comment #1)
> Not reproducible in
> 
> Version: 7.2.0.4 (x86) / LibreOffice Community
> Build ID: 9a9c6381e3f7a62afc1329bd359cc48accb6435b
> CPU threads: 2; OS: Windows 6.1 Service Pack 1 Build 7601; UI render:
> default; VCL: win
> Locale: es-ES (es_ES); UI: es-ES
> Calc: threaded
> 
> To be certain the reported issue is not related to corruption in the user
> profile, could you please reset your Libreoffice profile (
> https://wiki.documentfoundation.org/UserProfile ) and re-test?
> 
> I have set the bug's status to 'NEEDINFO'. Please change it back to
> 'UNCONFIRMED' if the issue is still present

Now in 
Version: 7.2.1.2 (x64) / LibreOffice Community
Build ID: 87b77fad49947c1441b67c559c339af8f3517e22
CPU threads: 4; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: sv-SE (en_GB); UI: en-GB
Calc: threaded

Started in safe mode and the tip of the day reverted to number 1 with the startup hint that it's a first-time use............
Perhaps tomorrow's startup will offer an alternate tip, 2 or 25 anybody's guess.

If it offers tip 2 I'll let you know what happens on October 24th 😎

If there's a way to keep my profile and all the user sort lists and just reset the tip counter then perhaps you could advise. Note, I have been using LO for more than 24 days - I imagine that's when I upgraded to 7.2.0.4 (I think from R6) and the upgrade killed my profile so I had to rebuild it the hard way. Recently updated to the current 7.2.1.2. Perhaps you could review which upgrade increments automatically reset the user profile because I think it resets between major releases 5. 6. 7. etc but it may be 7.0 to 7.1 to 7.2. I've heard rumours that upgrades don't (shouldn't) slug the profile but it's happened to me on numerous occasions so I can state quite categorically - it does, and regularly introduces "new" user sort lists because I can't speak Hebrew but somehow got their calendar.

Changing status back to 'UNCONFIRMED' on the assumption tomorrow gets me tip 24
Comment 3 Heiko Tietze 2021-09-30 12:34:17 UTC
In the expert options (tools > options > advanced > expert options), search for "tipoftheday". The entry LastTipOfTheDayID is the number of tip (22 in your case). More interesting is LastTipOfTheDayShow, which is compared with the current datetime showing the dialog after a day. Change the value to zero and check your system time.
Comment 4 Colin 2021-09-30 12:44:23 UTC
(In reply to Heiko Tietze from comment #3)
> In the expert options (tools > options > advanced > expert options), search
> for "tipoftheday". The entry LastTipOfTheDayID is the number of tip (22 in
> your case). More interesting is LastTipOfTheDayShow, which is compared with
> the current datetime showing the dialog after a day. Change the value to
> zero and check your system time.

Change the tip number to zero or the datetime to zero?
Comment 5 Heiko Tietze 2021-09-30 12:49:36 UTC
(In reply to Colin from comment #4)
> Change the tip number to zero or the datetime to zero?

The LastTipOfTheDayShow (should be a value like 18900). NEEDINFO for the report if this helped (and please remember to check your system time).
Comment 6 Colin 2021-09-30 12:59:44 UTC
Created attachment 175419 [details]
screen dump

I assume you were implying the tip of the day number which I have now reset to 0
Further update in 23 days time
Comment 7 Xisco Faulí 2021-09-30 13:12:02 UTC
(In reply to Colin from comment #6)
> Created attachment 175419 [details]
> screen dump
> 
> I assume you were implying the tip of the day number which I have now reset
> to 0
> Further update in 23 days time

keeping to NEEDINFO meanwhile
Comment 8 Colin 2021-09-30 13:15:40 UTC
(In reply to Xisco Faulí from comment #7)
> (In reply to Colin from comment #6)
> 
> keeping to NEEDINFO meanwhile

Yeah, on reflection, I guess that makes more sense 🤦‍♂️
Comment 9 Xisco Faulí 2021-09-30 13:19:18 UTC
yep
Comment 10 Colin 2021-10-01 13:15:53 UTC
(In reply to Xisco Faulí from comment #9)
> yep

That's unexpected.

Fresh start this morning with tip of the day 24.

Resetting the tip number to zero doesn't appear to survive a shutdown.

Tomorrow, I will try confirming jump to next tip a couple of times and see what happens on Sunday.

It may also prove appropriate to change the counter to something higher and see what happens.

At the end of the day, I could always change my mind and not bother with tips 🤷‍♂️

Leaving the status as NEEDINFO seems somehow appropriate.
Comment 11 QA Administrators 2021-10-02 03:40:47 UTC Comment hidden (obsolete)
Comment 12 Heiko Tietze 2021-10-06 07:54:11 UTC
Confirming that tips don't progress anymore in v7.2 and 7.3. No idea why but I will look into it.
Comment 13 Colin 2021-10-06 07:59:31 UTC
(In reply to Heiko Tietze from comment #12)
> Confirming that tips don't progress anymore in v7.2 and 7.3. No idea why but
> I will look into it.

My latest tests show that manually viewing "next tip" still sticks at whatever was the latest viewed tip.
I have just advanced the tipoftheday parameter manually to 30 but won't know until tomorrow whether this has any impact. Will advise.
Comment 14 Heiko Tietze 2021-10-07 09:20:55 UTC
*** Bug 143629 has been marked as a duplicate of this bug. ***
Comment 15 Commit Notification 2021-10-07 11:47:08 UTC
Heiko Tietze committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/1b6b2eff9ac386fd994e3ae120882f646268a80b

Resolves tdf#144693 - TipOfTheDay does not progress

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2021-10-08 08:21:29 UTC
Heiko Tietze committed a patch related to this issue.
It has been pushed to "libreoffice-7-2":

https://git.libreoffice.org/core/commit/9108fc6fe0b21ba06f155942f556275219f4eac0

Resolves tdf#144693 - TipOfTheDay does not progress

It will be available in 7.2.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.