Bug 144701 - Query Column Attributes Not Saved
Summary: Query Column Attributes Not Saved
Status: RESOLVED DUPLICATE of bug 86315
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
7.2.1.1 rc
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-09-24 08:30 UTC by flywire
Modified: 2021-09-25 07:39 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description flywire 2021-09-24 08:30:13 UTC
Column attributes should be saved with query.

1. Open Media_without_Macros.odb from https://wiki.documentfoundation.org/images/5/52/Sample-databases.zip
2. Query, Select Current_Date, Edit, Run,
2a. Right-Click a Column Header, Column Format, Format Category Date 31 Dec 1999 OK
2b. Right-Click a Column Header, Column Width, Width 5cm OK
3 File, Save, Close
4. Query, Select Current_Date, Right-Click, Open
5. Format attributes not retained

Version: 7.2.0.3 (x64) / LibreOffice Community
Build ID: 2a7ea282da28d665a7dc086360567b4aea27bf08
CPU threads: 8; OS: Windows 10.0 Build 19043; UI render: Skia/Raster; VCL: win
Locale: en-AU (en_AU); UI: en-GB
Calc: threaded
Comment 1 Alex Thurgood 2021-09-24 11:23:12 UTC
Thought that this had already been reported ages ago, but a quick trawl of bugzilla didn't bring it up.

Confirming.

Tested on

Version: 7.1.6.2 / LibreOffice Community
Build ID: 0e133318fcee89abacd6a7d077e292f1145735c3
CPU threads: 8; OS: Mac OS X 10.16; UI render: default; VCL: osx
Locale: fr-FR (fr_FR.UTF-8); UI: fr-FR
Calc: threaded

against a mysql database containing a query that by default displays the date as DD/MM/YY.

Try to format the date column in the query grid to DD/MM/YYYY, validate the format dialog, and the date is displayed as desired.

Now close the query grid view. The user isn't asked whether they want to save the formatting change, nor does any indication in the main DB window show that a change has occurred.

Now re-execute the query, the default date display is back again.

Pretty certain that this has always been like this since OOo3.0.
Comment 2 Alex Thurgood 2021-09-24 11:25:47 UTC
This probably has something to do with the XML attributes that should be saved to the ODB file. 

Perhaps these attributes don't even exist (I haven't checked), and therefore it is more the case of a missing implementation.
Comment 3 Robert Großkopf 2021-09-25 07:34:21 UTC
See also bug 60539.

Note: Query will be preformatted by the formatting of the table. but this would never work with the special query of this report, which doesn't show any field of a table.
Comment 4 Robert Großkopf 2021-09-25 07:37:53 UTC
Seems to be a duplicate of bug 86315. I will set this one to DUPLICATE. Feel free to reopen if you see differences there.

*** This bug has been marked as a duplicate of bug 86315 ***
Comment 5 Alex Thurgood 2021-09-25 07:39:39 UTC
Knew I'd seen it before, thanks Robert.