Bug 144704 - Dark theme is not applied to the sidebar, making dark icons invisible or hard to see
Summary: Dark theme is not applied to the sidebar, making dark icons invisible or hard...
Status: RESOLVED DUPLICATE of bug 118320
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.2.1.1 rc
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-09-24 11:08 UTC by guillaume.web
Modified: 2021-10-04 18:44 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Dark Theme not applied to side bar (119.07 KB, image/png)
2021-09-24 11:14 UTC, guillaume.web
Details

Note You need to log in before you can comment on or make changes to this bug.
Description guillaume.web 2021-09-24 11:08:29 UTC
Description:
When the dark theme is selected, the side bar stays in the default color. As a result, dark icons selected to go with the dark theme are hard to see or invisible on the light background.

The dark theme is also not applied to the bottom bar. I'm not sure if it is by design, but as there are no themed icons there it is not as bad anyway.

Steps to Reproduce:
1. Start Writer
2. Select the dark theme in the options
3. Select a set of dark icons
4. Navigate in the different sections of the side bar (properties, styles, etc...)
5. Notice that the dark theme is not applied to any of them

Actual Results:
The dark theme is not applied to the side bar and bottom bar. The icons in the side bar are hard to see.

Expected Results:
The dark theme should be applied to all the UI elements, especially those with themed icons.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
This was actually found in version 7.2.1.2 (not in the version list)
Comment 1 guillaume.web 2021-09-24 11:14:33 UTC
Created attachment 175245 [details]
Dark Theme not applied to side bar
Comment 2 Deep17 2021-09-28 16:37:39 UTC
I can reproduce this to stable and master build. But not sure if it is by design. However I can see all the icons as expected in the dark theme mode.

Version: 7.2.1.2 (x64) / LibreOffice Community
Build ID: 87b77fad49947c1441b67c559c339af8f3517e22
CPU threads: 8; OS: Windows 10.0 Build 17763; UI render: Skia/Vulkan; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: threaded

Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: a78190da867864485b5d0a91238616bd4090b5b5
CPU threads: 8; OS: Windows 10.0 Build 17763; UI render: Skia/Vulkan; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: threaded
Comment 3 guillaume.web 2021-09-28 16:56:36 UTC
(In reply to deepoose2011 from comment #2)
> I can reproduce this to stable and master build. But not sure if it is by
> design. However I can see all the icons as expected in the dark theme mode.
> 
> Version: 7.2.1.2 (x64) / LibreOffice Community
> Build ID: 87b77fad49947c1441b67c559c339af8f3517e22
> CPU threads: 8; OS: Windows 10.0 Build 17763; UI render: Skia/Vulkan; VCL:
> win
> Locale: en-US (en_US); UI: en-US
> Calc: threaded
> 
> Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
> Build ID: a78190da867864485b5d0a91238616bd4090b5b5
> CPU threads: 8; OS: Windows 10.0 Build 17763; UI render: Skia/Vulkan; VCL:
> win
> Locale: en-US (en_US); UI: en-US
> Calc: threaded

Ok I tested a bit more and it seems that the icon set I am using (Breeze Dark) is more problematic than others. Since the icons are so light, they become invisible or very hard to see in the sidebar. I tried with other icon sets, including Sifr Dark and visibility is not an issue.

If the sidebar is not themed by design, then Breeze Dark needs to be modified in order to be visible on the side bar.
Comment 4 Buovjaga 2021-10-04 15:01:14 UTC
The elements like the Sidebar are themed based on your operating system. For example, if with Linux KDE Plasma I change the colour theme to Breeze Dark and use Breeze Dark icons in LibreOffice, everything is fine because the Sidebar background colour is dark.
Comment 5 guillaume.web 2021-10-04 18:20:02 UTC
Hi @Buovjaga, so this may be a Windows specific bug. Despite my Windows theme being dark, the side bar and bottom bar background color in LibreOffice is light. Let me know if any specific info about my system configuration would help to pinpoint the issue, I would be happy to provide them. I can also cross-check on Fedora if you think it can be related to my hardware in some way.

I'm also wondering what the rationale is behind having some elements themed by the OS and other themed by the libre office configuration. Why would anyone want to have some element light and some element dark... Wouldn't it be better to either have it all follow the OS theme or all be set through the LibreOffice configuration?
Comment 6 Buovjaga 2021-10-04 18:44:20 UTC

*** This bug has been marked as a duplicate of bug 118320 ***