Bug 144724 - Can't move right our left using the Keyboard after enter Arabic language in Calc Cell
Summary: Can't move right our left using the Keyboard after enter Arabic language in C...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
7.2.0.4 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: RTL-UI
  Show dependency treegraph
 
Reported: 2021-09-25 16:42 UTC by almalkem
Modified: 2021-11-13 05:47 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description almalkem 2021-09-25 16:42:52 UTC
Description:
if i was using libreoffice 7.2 calc and writing arabic words inside cells, if I click enter it goes down. that is fine. but if i move by keyboard buttons right or left it doesn't work. but if language of content is english it works. in arabic content it doesn't work

Steps to Reproduce:
1.open file in libreoffice calc
2.try to write arabic word
3.you can click enter, it will go automatically to down sell. but can't move to left or right cell. but if language of content in cells were english, it will move up or down or left or right by keyboard buttons noramlly

Actual Results:
it doesn't go to right or left cell until I use mouse

Expected Results:
they should just make it recognizable when using keyboard to go to left cell or right cell not only down cell.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.2.0.4 / LibreOffice Community
Build ID: ce769e3009755dcf0082844e386f5dca4c8ecb2f
CPU threads: 8; OS: Linux 5.11; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 1 Eyal Rozenberg 2021-11-12 17:17:29 UTC
This sounds like some sort of issue with keyboard layout on your system. I've never experienced something like this, and it sounds unlikely, as movement between cells should not affected by the language of the cell's contents.

Anyway, can't reproduce.

If you can reproduce this on different systems (try different Linux distributions / desktop environments, and perhaps Windows) - please reopen, although I really doubt that could be the case.