Bug 144734 - some arabic letters unrecognized
Summary: some arabic letters unrecognized
Status: UNCONFIRMED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
7.2.0.4 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: RTL-Arabic
  Show dependency treegraph
 
Reported: 2021-09-26 13:15 UTC by almalkem
Modified: 2021-11-13 11:50 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
it shows how wrong wrod appears if using with arabic lang (3.26 KB, image/png)
2021-09-26 13:15 UTC, almalkem
Details

Note You need to log in before you can comment on or make changes to this bug.
Description almalkem 2021-09-26 13:15:39 UTC
Created attachment 175279 [details]
it shows how wrong wrod appears if using with arabic lang

Version: 7.2.0.4 / LibreOffice Community
Build ID: ce769e3009755dcf0082844e386f5dca4c8ecb2f
CPU threads: 8; OS: Linux 5.11; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded


when i write this arabic word (الاملاء) inside cell and before I write it I click on 
1- then the word, then the word looks wrong


it should look like this
1- الاملاء
however, when I click on number 1 then use - then the word, it looks like unread.

see attachment
Comment 1 Eyal Rozenberg 2021-11-12 17:20:23 UTC
Please tell us...

* Which LibreOffice application are you using? Writer? Calc? 
* Which font are you using (for European LTR scripts and for the Arabic)?

For now, I can't reproduce.
Comment 2 almalkem 2021-11-13 11:50:08 UTC
it's calc
regarding the font, am not sure which to do to find the info