Bug 144742 - UI: Font Color and Background Color toolbuttons' popups fail to select color from color grid (regression)
Summary: UI: Font Color and Background Color toolbuttons' popups fail to select color ...
Status: RESOLVED DUPLICATE of bug 144037
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.2.1.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-09-26 20:43 UTC by phd
Modified: 2021-11-18 20:06 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description phd 2021-09-26 20:43:15 UTC
Clicking on a down-arrow next to Font Color and Background Color toolbuttons opens a popup windows with color grid and some other buttons.

However when you try to select any color from the grid, the popup disappears and the chosen color is not selected. Color in the document also does not change.

In fact any mouse click in that popup (color grid scrollbar, checkbox, buttons, etc.) closes the popup without interacting with its contents at all.

The popup controls work fine when using keyboard (Tab, arrows, Enter) to navigate and select color.

This worked perfectly fine before, so it is a (very problematic) regression.

Affected versions: Writer 7.2.1.2, Calc 7.2.1.2 (Kubuntu 21.04 packages)
Comment 1 Mike Kaganski 2021-09-27 06:08:22 UTC

*** This bug has been marked as a duplicate of bug 144037 ***