Bug 144761 - Crash in: SvTreeListEntry::NextSibling()
Summary: Crash in: SvTreeListEntry::NextSibling()
Status: RESOLVED DUPLICATE of bug 144564
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.1.5.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-09-28 11:07 UTC by Robert
Modified: 2021-09-29 08:54 UTC (History)
2 users (show)

See Also:
Crash report or crash signature: ["SvTreeListEntry::NextSibling()"]
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert 2021-09-28 11:07:19 UTC
This bug was filed from the crash reporting server and is br-69a38768-2727-486b-9c39-e90c3b14b947.
=========================================

Simple to reproduce, just try Shift+Control+F4 to bring up the database sources for queries within a sheet that has a direct Database selection.
Comment 1 Xisco Faulí 2021-09-28 12:33:56 UTC
Not reproducible in

Version: 7.2.0.4 (x86) / LibreOffice Community
Build ID: 9a9c6381e3f7a62afc1329bd359cc48accb6435b
CPU threads: 2; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: default; VCL: win
Locale: ar-DZ (es_ES); UI: es-ES
Calc: threaded

Does it happen with any document? How many databases do you have registered ?
Comment 2 Robert 2021-09-28 12:40:16 UTC
There are four databases registered.

It does not crash if there is no query in the sheet.
Comment 3 Julien Nabet 2021-09-28 18:44:05 UTC
Caolán: just to be sure, isn't it already fixed, at least in master branch with https://cgit.freedesktop.org/libreoffice/core/commit/?id=2a357832b9eedea161f593c1b3bf8dd973949c95 ?
Comment 4 NISZ LibreOffice Team 2021-09-29 06:49:43 UTC
(In reply to Julien Nabet from comment #3)
> Caolán: just to be sure, isn't it already fixed, at least in master branch
> with
> https://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=2a357832b9eedea161f593c1b3bf8dd973949c95 ?

This is likely a duplicate of that (but bug 144564 was the correct number fixed by that commit).
bug 144461 and bug 144491 sound like the same as well.
Comment 5 Xisco Faulí 2021-09-29 08:54:05 UTC
(In reply to NISZ LibreOffice Team from comment #4)
> (In reply to Julien Nabet from comment #3)
> > Caolán: just to be sure, isn't it already fixed, at least in master branch
> > with
> > https://cgit.freedesktop.org/libreoffice/core/commit/
> > ?id=2a357832b9eedea161f593c1b3bf8dd973949c95 ?
> 
> This is likely a duplicate of that (but bug 144564 was the correct number
> fixed by that commit).
> bug 144461 and bug 144491 sound like the same as well.

I agree. Closing as duplicated

*** This bug has been marked as a duplicate of bug 144564 ***
Comment 6 Xisco Faulí 2021-09-29 08:54:47 UTC
@Robert, the fix for this crash will be available in LibreOffice 7.2.2, due to be released in two weeks from now