Bug 144791 - Crash when modifying Styles in Calc
Summary: Crash when modifying Styles in Calc
Status: RESOLVED DUPLICATE of bug 144729
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.3.0.0 alpha0+
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, haveBacktrace, regression
Depends on:
Blocks:
 
Reported: 2021-09-29 10:38 UTC by Kevin Suo
Modified: 2021-09-29 11:39 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
gdbtrace.log (28.55 KB, text/x-log)
2021-09-29 10:38 UTC, Kevin Suo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Suo 2021-09-29 10:38:14 UTC
Created attachment 175350 [details]
gdbtrace.log

Steps to Reproduce:
1. New Calc
2. Right-click on the "Default" style in the Styles deck, then click "Edit".

--> Crash.

Version: 7.3.0.0.alpha0+ / LibreOffice Community
Build ID: a78190da867864485b5d0a91238616bd4090b5b5
CPU threads: 8; OS: Linux 5.13; UI render: default; VCL: gtk3
Locale: zh-CN (zh_CN.UTF-8); UI: zh-CN
Calc: threaded

Fedora 32.

GDB Backtrace attached.
Comment 1 Kevin Suo 2021-09-29 10:46:50 UTC
Bibisected to the following range:
d1e14030e81ff2bbe4bcb3706a9f21672a368074..27f3618a600006e59d6b45e22f0eb46457172a52

and revert the following commit fixes the issue:
commit c9b19f69e658f1114f1b8fc0ae62b6edd6d33e3f
Author: Caolán McNamara <caolanm@redhat.com>
Date:   Wed Sep 22 16:26:00 2021 +0100

    Resolves: tdf#142704 %PRODUCTNAME shown in gtk3 extended tips

Adding Caolán to cc, would you please take a look? Thanks.
Comment 2 Xisco Faulí 2021-09-29 10:57:48 UTC
not reproduced in

Version: 7.3.0.0.alpha0+ / LibreOffice Community
Build ID: ac34bafb6cad056f843ff3ff0dee293bf1e18c56
CPU threads: 4; OS: Linux 5.10; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 3 Caolán McNamara 2021-09-29 11:39:49 UTC

*** This bug has been marked as a duplicate of bug 144729 ***