Bug 144808 - Add some triangle to Text color and Background color items in Autofilter window
Summary: Add some triangle to Text color and Background color items in Autofilter window
Status: RESOLVED DUPLICATE of bug 144410
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.3.0.0 alpha0+
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: AutoFilter-Color
  Show dependency treegraph
 
Reported: 2021-09-29 14:19 UTC by Roman Kuznetsov
Modified: 2021-09-30 08:56 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
a mockup here (15.07 KB, image/jpeg)
2021-09-29 14:19 UTC, Roman Kuznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2021-09-29 14:19:00 UTC
Description:
Add some triangle to Text color and Background color items in Autofilter window

We have an opportunity to filter items by background color and by text color in Autofilter window. But those items don't have some visual elements to show there is a sublevel for those items as it made in Excel.

I suggest to Add some triangle to Text color and Background color items in Autofilter window (look at mockup in attach

Steps to Reproduce:
-

Actual Results:
We don't see background color and by text color items in Autofilter window have submenu/subitems

Expected Results:
background color and by text color items in Autofilter window have some visual elements to show there are submenu/subitems


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 1516711eb7861a08cc9fd19ec867360737a6d070
CPU threads: 8; OS: Windows 10.0 Build 19043; UI render: Skia/Vulkan; VCL: win
Locale: ru-RU (ru_RU); UI: en-US
Calc: threaded
Comment 1 Roman Kuznetsov 2021-09-29 14:19:32 UTC
Created attachment 175371 [details]
a mockup here
Comment 2 Roman Kuznetsov 2021-09-29 14:20:34 UTC
Samuel, Heiko what do you think?
Comment 3 Xisco Faulí 2021-09-29 15:58:01 UTC
+1 from me
Comment 4 Heiko Tietze 2021-09-30 07:57:52 UTC
The triangle indicator is used for submenus but this selection widget is not a menu. We could add ellipsis to the text ("Text color...").

But yes, as it is now it has potential for confusion.
Comment 5 NISZ LibreOffice Team 2021-09-30 08:35:46 UTC
Duplicate of bug 144410 :)
Comment 6 Heiko Tietze 2021-09-30 08:56:50 UTC

*** This bug has been marked as a duplicate of bug 144410 ***