Bug 144845 - Pop-up dialog while opening a read-only file
Summary: Pop-up dialog while opening a read-only file
Status: RESOLVED DUPLICATE of bug 143971
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.2.1.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-09-30 20:32 UTC by Lant
Modified: 2021-10-01 20:21 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lant 2021-09-30 20:32:17 UTC
Description:
Since upgrade LO to version 7.2 I stucked with unpleasant dialogue
"Document is read-only. Open read-only or select Notify... etc"
Three buttons. WHY? I open many hundreds *.odt files, many of these files protected from accidental deletion with read-only attribute. Okay, click open/ and see another, old information string "This document open read-only", and button "Edit" on right corner, and a cross to close string. I does not understand. Why first popup dialogue appears? Information string is not enought to select action? Is this really necessary? I know, I see that opening read-only file need to upgrade. But this way is wrong.

What I offer to do. Move buttons of new popup dialogue to information string appears above document what opened read-only. Instead one button "Edit" - add new button "Notify". There is a more user-friendly dialogue. We see documents with one click, and then decide, what we do later: open read-only, notify other user or open to editing.


Steps to Reproduce:
1. Make document a read-only with file attribute
2. Open it

Actual Results:
We see a dialogue that unnecessary to open file

Expected Results:
Open a document without these dialogue!


Reproducible: Always


User Profile Reset: No



Additional Info:
Another information string while opening a read-only document.
Comment 1 Ezinne 2021-10-01 19:45:14 UTC
UX Team -- please take a look at this enhancement. Thanks!
Comment 2 Roman Kuznetsov 2021-10-01 20:21:18 UTC

*** This bug has been marked as a duplicate of bug 143971 ***