Bug 144872 - New color filter is broken -> Freeze
Summary: New color filter is broken -> Freeze
Status: RESOLVED DUPLICATE of bug 142420
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.2.1.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-10-02 09:17 UTC by Andreas Säger
Modified: 2021-10-21 07:36 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Auto-filter by yellow background (8.20 KB, application/vnd.oasis.opendocument.spreadsheet)
2021-10-05 10:02 UTC, Andreas Säger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Säger 2021-10-02 09:17:06 UTC
Create a small list with column header, highlight an entry with font colour, add auto-filter, choose "Text color" from auto-filter menu. This should hide all rows except the header row and the red one. 
With Ubuntu 18.4 (gtk with Wayland) it does nothing. Without Wayland (gtk with X11 server) it works so far.

If the filtering worked, choose "Text color" again from the auto-filter menu in order to turn the filter off again.
Result: Frozen application. 
xkill can't grab cursor. 
killall -9 soffice.bin is needed.
Comment 1 Julien Nabet 2021-10-02 17:52:41 UTC
How did you install LO 7.1.2 ? From LO website, from LO ppa, other?
Also, could you upgrade to Ubuntu 20.04 (if you want to stick to LTS) or Ubuntu 21.04 ?
I mean Wayland is quite new so a recent Ubuntu version may help.
Comment 2 Andreas Säger 2021-10-02 22:01:37 UTC
(In reply to Julien Nabet from comment #1)
> How did you install LO 7.1.2 ? From LO website, from LO ppa, other?
> Also, could you upgrade to Ubuntu 20.04 (if you want to stick to LTS) or
> Ubuntu 21.04 ?
> I mean Wayland is quite new so a recent Ubuntu version may help.

My LO 7.2.1 was downloaded from https://libreoffice.org. The new feature does not work (Wayland) or it makes the program freeze (X11). Apart from that, it should never have been implemented. Treating formatting attributes as values is a mistake, even if Excel does the same bullshit.
Comment 3 Julien Nabet 2021-10-03 19:02:35 UTC
You should uninstall LO 7.1.2 since Linux packages on libreoffice.org are more for   Linux distrib repositories maintainers.

You can give a try to LO ppa (see https://launchpad.net/~libreoffice/+archive/ubuntu/ppa).
Also, try to upgrade to 20.04 as indicated.

About "treating formatting attributes as values", I don't know but that's another story.
Comment 4 Xisco Faulí 2021-10-04 09:51:56 UTC
Thanks for reporting this issue.
This looks like a duplicate of bug 144037

*** This bug has been marked as a duplicate of bug 144037 ***
Comment 5 Andreas Säger 2021-10-04 12:35:55 UTC
(In reply to Xisco Faulí from comment #4)
> Thanks for reporting this issue.
> This looks like a duplicate of bug 144037
> 
> *** This bug has been marked as a duplicate of bug 144037 ***

Sure? This bug describes the failure of a brand new Calc feature. #144037 describes a regression in Writer.
Comment 6 Buovjaga 2021-10-04 17:57:25 UTC
(In reply to Andreas Säger from comment #5)
> (In reply to Xisco Faulí from comment #4)
> > Thanks for reporting this issue.
> > This looks like a duplicate of bug 144037
> > 
> > *** This bug has been marked as a duplicate of bug 144037 ***
> 
> Sure? This bug describes the failure of a brand new Calc feature. #144037
> describes a regression in Writer.

Do you reproduce, if running with

SAL_USE_VCLPLUGIN=gen libreoffice
Comment 7 Andreas Säger 2021-10-04 22:34:50 UTC
(In reply to Buovjaga from comment #6)
> (In reply to Andreas Säger from comment #5)
> > (In reply to Xisco Faulí from comment #4)
> > > Thanks for reporting this issue.
> > > This looks like a duplicate of bug 144037
> > > 
> > > *** This bug has been marked as a duplicate of bug 144037 ***
> > 
> > Sure? This bug describes the failure of a brand new Calc feature. #144037
> > describes a regression in Writer.
> 
> Do you reproduce, if running with
> 
> SAL_USE_VCLPLUGIN=gen libreoffice

Yes, I do.
Comment 8 Buovjaga 2021-10-05 05:13:43 UTC
It's true that this is not a dupe of bug 144037 because this is reported to happen with gtk3 and gen for starters.

I can't reproduce, though.

Might be a good idea to test in Safe mode as well https://wiki.documentfoundation.org/UserProfile

With X11 session on Arch Linux
Version: 7.2.1.2 / LibreOffice Community
Build ID: 20(Build:2)
CPU threads: 8; OS: Linux 5.14; UI render: default; VCL: gtk3
Locale: fi-FI (fi_FI.UTF-8); UI: fi-FI
7.2.1-2
Calc: threaded
Comment 9 Andreas Säger 2021-10-05 10:00:53 UTC
SAL_USE_VCLPLUGIN=gen libreoffice7.2 --safe-mode /tmp/yellow_filter.ods 

Click auto-filter
Background > Yellow box
Filters as expected

Click auto-filter
Background > Yellow box
Freeze
Comment 10 Andreas Säger 2021-10-05 10:02:12 UTC
Created attachment 175536 [details]
Auto-filter by yellow background
Comment 11 Buovjaga 2021-10-05 10:08:24 UTC
(In reply to Andreas Säger from comment #9)
> SAL_USE_VCLPLUGIN=gen libreoffice7.2 --safe-mode /tmp/yellow_filter.ods 
> 
> Click auto-filter
> Background > Yellow box
> Filters as expected
> 
> Click auto-filter
> Background > Yellow box
> Freeze

Oh, for that there is already a report, closing as duplicate

*** This bug has been marked as a duplicate of bug 144320 ***
Comment 12 Buovjaga 2021-10-21 07:36:37 UTC

*** This bug has been marked as a duplicate of bug 142420 ***