Bug 144931 - 300k x 100k vlookup lead to crash
Summary: 300k x 100k vlookup lead to crash
Status: RESOLVED DUPLICATE of bug 139444
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.2.1.2 release
Hardware: All macOS (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Function-Vlookup
  Show dependency treegraph
 
Reported: 2021-10-05 05:42 UTC by tagishsimon
Modified: 2022-05-11 10:06 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
ods spreadsheet which will exhibit crash (2.80 MB, application/vnd.oasis.opendocument.spreadsheet)
2021-10-05 05:42 UTC, tagishsimon
Details
apple crash report (119.31 KB, text/plain)
2021-10-05 05:43 UTC, tagishsimon
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tagishsimon 2021-10-05 05:42:47 UTC
Created attachment 175521 [details]
ods spreadsheet which will exhibit crash

The attached file crashes (libreoffice 7.2.1.2 on macOS 11.6 (20G165)) whilst trying to complete a large set of VLOOKUPs - circa 300k vlookups to a 100k range

Method:
copy the formula in sheet1:a2, to the range a3::a302461

Expected result:
spreadsheet completes a vlookup

Actual result
libreoffice crashes
Comment 1 tagishsimon 2021-10-05 05:43:51 UTC
Created attachment 175522 [details]
apple crash report
Comment 2 Roman Kuznetsov 2021-10-05 12:29:53 UTC
No crash, but there is a long delay for action complete

Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: fbfd91f2c5f4d66570c2d5a6f048b21f5d1671a4
CPU threads: 8; OS: Windows 10.0 Build 19043; UI render: Skia/Vulkan; VCL: win
Locale: ru-RU (ru_RU); UI: ru-RU
Calc: threaded

Please write here an info from LibreOffice-About dialog (as I did it above)
Comment 3 tagishsimon 2021-10-05 12:51:27 UTC
crash occurred on:

Version: 7.2.1.2 / LibreOffice Community
Build ID: 87b77fad49947c1441b67c559c339af8f3517e22
CPU threads: 8; OS: Mac OS X 11.6; UI render: default; VCL: osx
Locale: en-GB (en_GB.UTF-8); UI: en-US
Calc: threaded
Comment 4 tagishsimon 2021-10-05 13:18:00 UTC
And I confirm it's repeatable at my end.
Comment 5 Roman Kuznetsov 2021-10-06 20:14:08 UTC
Interesting, I confirm the crash in macOS after too long hang

Version: 7.3.0.0.alpha0+ / LibreOffice Community
Build ID: 559850da1f48fd7ea521c78a1867255212f7aee9
CPU threads: 4; OS: Mac OS X 10.16; UI render: Skia/Raster; VCL: osx
Locale: ru-RU (ru_RU.UTF-8); UI: en-US
Calc: threaded
Comment 6 Luboš Luňák 2022-05-11 10:06:38 UTC

*** This bug has been marked as a duplicate of bug 139444 ***