Bug 144969 - EDIT: no dead keys in comments
Summary: EDIT: no dead keys in comments
Status: RESOLVED DUPLICATE of bug 71437
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.2.1.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Comments Languages
  Show dependency treegraph
 
Reported: 2021-10-06 15:06 UTC by Christian Lehmann
Modified: 2021-12-16 15:54 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Lehmann 2021-10-06 15:06:44 UTC
Description:
Version 7.2.2.1: When writing inside a comment, "dead" keys (', `, ^) are ignored. For instance, when typing á, only a appears.

Steps to Reproduce:
1. Open a comment (CTRL-ALT-C).
2. Type á.

Actual Results:
a

Expected Results:
á


Reproducible: Always


User Profile Reset: No



Additional Info:
This is apparently brand-new in:
Version: 7.2.2.1 / LibreOffice Community
Build ID: 20(Build:1)
CPU threads: 12; OS: Linux 5.3; UI render: default; VCL: gtk3
Locale: de-DE (de_DE.UTF-8); UI: en-US
Calc: threaded
Comment 1 Dieter 2021-10-26 11:32:55 UTC
I can't reproduce in

Version: 7.2.2.2 (x64) / LibreOffice Community
Build ID: 02b2acce88a210515b4a5bb2e46cbfb63fe97d56
CPU threads: 4; OS: Windows 10.0 Build 19043; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: CL

Does it also happen in SafeMode?

=> NEEDINFO
Comment 2 Christian Lehmann 2021-10-26 12:37:53 UTC
Yes.

This is on OpenSuse Leap 15.2, Gnome 3.34.7.

What else can I do to find the source of the problem?
Comment 3 Dieter 2021-10-26 14:00:40 UTC
(In reply to Christian Lehmann from comment #2)
> What else can I do to find the source of the problem?

If you're sure, that this is a new bug, that wasn't in previous versions, you can install a previous version in parallel (user guide: https://wiki.documentfoundation.org/Installing_in_parallel/Linux) and try to find a version without that bug.
Comment 4 Hans Deragon 2021-10-31 19:49:35 UTC
Copying the comment I have done on bug #71437, which are maybe, maybe not related.

Confirming still having this problem with:

Version: 7.2.2.2 / LibreOffice Community
Build ID: 20(Build:2)
CPU threads: 4; OS: Linux 5.11; UI render: default; VCL: gtk3
Locale: en-CA (en_CA.utf8); UI: en-US
Ubuntu package version: 1:7.2.2~rc2-0ubuntu0.20.04.1~lo1
Calc: threaded
OS:  Linux Ubuntu 20.04 LTS.

However, in the main windows the dead keys are working.  It is on some side widgets they are not.  For instance:

- In writer, dead keys work when typing in the main text area.  However, they do not work in comment boxes.
- In Calc, dead keys work when typing in the cell.  If typing in the upper formula bar, they do not work.

Tried 'unset XMODIFIERS' to no vail.
Comment 5 Christian Lehmann 2021-12-15 07:42:11 UTC
I finally got around to testing the bug on different systems. The results for dead keys in LO Writer comments are:

For LO versions 6.1, 7.0.4.2 and 7.2.4.1, they work on Windows 10.

For LO versions 7.0 and 7.2.4.1, they do not work on OpenSuse Leap 15.2.

For LO version 6.4, they work on Lubuntu 14.4.

I recognize that this test is not wholly systematic (my resources are limited). Nevertheless, it does seem that the bug is 1) new in LO version 7 and 2) limited to Linux.

Needless to say, dead keys do work in all other application environments on Linux systems.
Comment 6 QA Administrators 2021-12-16 04:09:28 UTC Comment hidden (obsolete)
Comment 7 Dieter 2021-12-16 15:54:45 UTC
Regarding to bug 71437 comment 35, I would treat it as a duplicate. Feel free to change it back to NEW (because Hans confirmed the problem) with a short reasoning, if you disagree.

*** This bug has been marked as a duplicate of bug 71437 ***