Bug 144993 - unable to use menus with kf5+wayland
Summary: unable to use menus with kf5+wayland
Status: RESOLVED DUPLICATE of bug 144585
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.2.1.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2021-10-08 07:43 UTC by giors_00
Modified: 2021-10-12 10:16 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Screencast showing the bug (3.30 MB, video/mp4)
2021-10-08 07:44 UTC, giors_00
Details

Note You need to log in before you can comment on or make changes to this bug.
Description giors_00 2021-10-08 07:43:27 UTC
Description:
Internal menus do not works (unusable) in plasma. 

Steps to Reproduce:
1.open libreoffice in plasma + wayland
2.try to use a drop-down menu (f.e. font, font size...)
3.

Actual Results:
Impossible to use the menu

Expected Results:
the drop down menu is usable


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Alsa tried with Libreoffice 7.3 alpha and problem is still there. With SAL_USE_VCLPLUGIN=gtk3 it works ok (but limited functions under kde plasma).With QT_QPA_PLATFORM=xcb libreoffice works ok.   

Version: 7.2.1.2 / LibreOffice Community
Build ID: 20(Build:2)
CPU threads: 4; OS: Linux 5.14; UI render: default; VCL: kf5 (cairo+wayland)
Locale: es-ES (es_ES.UTF-8); UI: es-ES
7.2.1-2
Calc: threaded
Comment 1 giors_00 2021-10-08 07:44:40 UTC
Created attachment 175591 [details]
Screencast showing the bug
Comment 2 Mike Kaganski 2021-10-08 08:06:03 UTC

*** This bug has been marked as a duplicate of bug 144037 ***
Comment 3 giors_00 2021-10-08 08:19:22 UTC
Just would like to let you know that I have tried with 7.3 alpha daily (downloaded yesterday) and the problem has not been solved.
Comment 4 Jan-Marek Glogowski 2021-10-08 08:34:30 UTC
(In reply to giors_00 from comment #3)
> Just would like to let you know that I have tried with 7.3 alpha daily
> (downloaded yesterday) and the problem has not been solved.

Yup - there was just a revert for 7-2. I'm trying to fix the real problem, but that turned out to be harder then expected, so for the time being 7-3 / master is broken.
Comment 5 Michael Weghorn 2021-10-12 10:16:03 UTC
Let's set this as a duplicate of the Wayland-specific tdf#144585, the X11 case (originally handled in tdf#144037) is fine in master as well.

*** This bug has been marked as a duplicate of bug 144585 ***