Bug 145004 - WordArt kind "Follow Path" are rendered with additional space
Summary: WordArt kind "Follow Path" are rendered with additional space
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.3.0 target:7.2.3
Keywords:
Depends on:
Blocks: FontWork-WordArt
  Show dependency treegraph
 
Reported: 2021-10-08 17:44 UTC by Regina Henschel
Modified: 2021-10-13 13:59 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Document with shape with ScaleX=true (15.70 KB, application/haansoftpptx)
2021-10-08 17:44 UTC, Regina Henschel
Details
Screenshot of PowerPoint and LibreOffice side-by-side (98.95 KB, image/png)
2021-10-08 17:44 UTC, Regina Henschel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2021-10-08 17:44:00 UTC
Created attachment 175601 [details]
Document with shape with ScaleX=true

Open attached document. It contains a WordArt of type 'Circle'. That is available in PowerPoint in section "Follow Path" in "abc Transform". The types 'Arch' and 'Arch Down' in that section have the same problem.

Error: It has a large gap at the left edge, which should not be there, see attached screenshot.

In LibreOffice these kind of shapes become a Fontwork with ScaleX=true in the TextPath property in the CustomShapeGeometry property. ScaleX=true means, that the text is not stretched to the path length but keeps its font size as far as possible.

This is not an error in the import filter, but such gap exists too in shapes from ODF documents. This gap is produced in method CalculateHorizontalScalingFactor in EnhancedCustomShapeFontWork.cxx

Our own Fontwork preset shapes are not affected, because they always use ScaleX=false.
Comment 1 Regina Henschel 2021-10-08 17:44:51 UTC
Created attachment 175602 [details]
Screenshot of PowerPoint and LibreOffice side-by-side
Comment 2 Roman Kuznetsov 2021-10-09 15:49:54 UTC
confirm in

Version: 7.3.0.0.alpha0+ / LibreOffice Community
Build ID: 559850da1f48fd7ea521c78a1867255212f7aee9
CPU threads: 4; OS: Mac OS X 10.16; UI render: Skia/Raster; VCL: osx
Locale: ru-RU (ru_RU.UTF-8); UI: en-US
Calc: threaded
Comment 3 Commit Notification 2021-10-13 11:28:59 UTC
Regina Henschel committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/4e1f5b5eaddac6ff4b3028074edc8f6886d64c3f

tdf#145004 remove fontwork text padding for case ScaleX=true

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2021-10-13 13:59:11 UTC
Regina Henschel committed a patch related to this issue.
It has been pushed to "libreoffice-7-2":

https://git.libreoffice.org/core/commit/9694118306cc733d08b590fffe7a176661534b7f

tdf#145004 remove fontwork text padding for case ScaleX=true

It will be available in 7.2.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.