Bug 145034 - UI: Animation not arrange alphabetically
Summary: UI: Animation not arrange alphabetically
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.3.0.0 alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 145035 (view as bug list)
Depends on:
Blocks: Sidebar-Animation
  Show dependency treegraph
 
Reported: 2021-10-10 08:47 UTC by Telesto
Modified: 2021-10-14 12:33 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2021-10-10 08:47:21 UTC
Description:
UI: Animation not arrange alphabetically 

Steps to Reproduce:
1. Open Impress
2. Select an textbox
3. Sidebar -> Animation Tab
4. Press +
5. Go through the list

Actual Results:
Arranged 'randomly' (no clue what the true pattern is)

Expected Results:
Alphabetically? 


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 93115d2c54d645bcf2f80fde325e3ede39dee4d5
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: en-US (nl_NL); UI: en-US
Calc: CL
Comment 1 Roman Kuznetsov 2021-10-10 19:04:12 UTC
Confirm in

Version: 7.3.0.0.alpha0+ / LibreOffice Community
Build ID: 80a47aae1419842f4496f02028e2b49763aea25b
CPU threads: 4; OS: Linux 5.10; UI render: default; VCL: gtk3
Locale: ru-RU (ru_RU.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2021-09-13_23:40:12
Calc: threaded

Andreas , I thought you can be interested with it (because you have made alphabetical sort for some things in LO already)
Comment 2 Heiko Tietze 2021-10-11 07:09:07 UTC
Seems to follow the definition in officecfg/registry/data/org/openoffice/Office/UI/Effects.xcu. But sorting this list wont work for localized terms. And actually I'd miss "Appear" (dt.: Erscheinen) at first position. "Fly In" is probably also an animation that many users apply to objects, etc. The rest of the list appears to be sorted to me. My take => NAB
Comment 3 Telesto 2021-10-11 07:21:00 UTC
(In reply to Heiko Tietze from comment #2)
> Seems to follow the definition in
> officecfg/registry/data/org/openoffice/Office/UI/Effects.xcu. But sorting
> this list wont work for localized terms. And actually I'd miss "Appear"
> (dt.: Erscheinen) at first position. "Fly In" is probably also an animation
> that many users apply to objects, etc. The rest of the list appears to be
> sorted to me. My take => NAB

1) Well for searching some specific entry, this pretty erratic :-). A list which does put stuff 'at random'

2) The language concern being absolute valid

3) What you're looking for is actually category commonly used, IMHO. And yes, I admit there are certain entry's more often used..
Comment 4 Heiko Tietze 2021-10-11 07:45:25 UTC
*** Bug 145035 has been marked as a duplicate of this bug. ***
Comment 5 Andreas Heinisch 2021-10-11 19:18:13 UTC
I could solve it, but is it really something we want here? Personally, I am not satisfied with arranging them alphabetically.

There are items which will be used more frequently than others. Maybe we can add a filter to the top of the list? Or change it to a treeview? Or apply some pseudosorting like the most common are at the top, then the others follow alphabetically?
Comment 6 Telesto 2021-10-11 22:56:43 UTC
(In reply to Andreas Heinisch from comment #5)
> I could solve it, but is it really something we want here? Personally, I am
> not satisfied with arranging them alphabetically.

Limiting it tot alphabetically sec probably doesn't work about

> 
> There are items which will be used more frequently than others. Maybe we can
> add a filter to the top of the list? Or change it to a treeview? Or apply
> some pseudosorting like the most common are at the top, then the others
> follow alphabetically?

Some solution must be found here indeed. Some related comments of Heiko

Bug 145037 comment 2: Heiko Tietze
"Ultimately I would limit the list to the last used n item (or even better animations including other attributes). See also bug 145038"

bug 145038 comment 2: Heiko Tietze

Don't like the idea. The dialog would just rearrange the controls, maybe provide a better overview of the effects but nothing beyond. The idea of the sidebar is to quickly access the most frequently used attributes while the full power of LibreOffice is presented in dialogs. So I'd rather think about simplifying the sidebar - could be done if we have "animation styles" (a template/preset to all settings) and show only these and limited to the last n used.

---
Sidenote: I have tendency to put the various idea's/proposed into different reports. With the advantage of getting a response to every ticket with long thread and a confusing debate, but with the cost that certain idea's get sprinkled across different bugs. So in the end some 'cumulative bug report must be created replacing the dozen of mine (IMHO)
Comment 7 Heiko Tietze 2021-10-14 12:27:47 UTC
The topic was on the agenda of the design meeting but hasn't received further input. Resolving NAB based on the previous input. Sorting is not an issue but rather carefully chosen.
Comment 8 Telesto 2021-10-14 12:33:52 UTC
(In reply to Heiko Tietze from comment #7)
> The topic was on the agenda of the design meeting but hasn't received
> further input. Resolving NAB based on the previous input. Sorting is not an
> issue but rather carefully chosen.

But rather unproductive if you are searching for specific animation ;-)