Bug 145057 - FILESAVE XLSX Color filter set in data range does not work
Summary: FILESAVE XLSX Color filter set in data range does not work
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.3.0.0 alpha0+
Hardware: All All
: medium normal
Assignee: Samuel Mehrbrodt (allotropia)
URL:
Whiteboard: target:7.4.0 target:7.3.0.2
Keywords: filter:xlsx, implementationError
: 145058 (view as bug list)
Depends on:
Blocks: AutoFilter-Color
  Show dependency treegraph
 
Reported: 2021-10-11 06:47 UTC by Gabor Kelemen (allotropia)
Modified: 2021-12-23 10:05 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
attachment 170421 modified with data range and color filter (6.62 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2021-10-11 06:47 UTC, Gabor Kelemen (allotropia)
Details
The example file in Calc and Excel side by side (89.85 KB, image/png)
2021-10-11 06:48 UTC, Gabor Kelemen (allotropia)
Details
A similar example file made from scratch (10.84 KB, application/vnd.oasis.opendocument.spreadsheet)
2021-10-11 06:48 UTC, Gabor Kelemen (allotropia)
Details
The similar example file works fine when saved as xlsx (6.06 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2021-10-11 06:49 UTC, Gabor Kelemen (allotropia)
Details
For reference: attachment 170421 modified in Excel (10.17 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2021-12-22 14:11 UTC, Gabor Kelemen (allotropia)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gabor Kelemen (allotropia) 2021-10-11 06:47:59 UTC
Created attachment 175638 [details]
attachment 170421 [details] modified with data range and color filter

When a data range is set in an existing XLSX file and an autofilter is set on the background color of the cells in that data range, after saving the file and reloading the color is not highlighted in the autofilter anymore.
This does not happen when the file is created in the Calc editor, only with existing XLSX files.

Steps to reproduce:
    1. Open attachment 170421 [details] from bug 140968
    2. Enter some data in the range D1:F3
    3. Select D1:F3, then Data – Define Range, enter a name in the Name box
    4. Enable the autofilter in the D1:F3 range 
    5. Set different cell background colors on D2 and D3
    6. Filter the column D with one of the background colors
    7. Save and reload the file.

Actual results:
Opening the autofilter on column D the Background color list does not highlight the previously set color.

Expected results:
The color should be saved and reloaded correctly.

LibreOffice details:
Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: b1488cd6f008049a9aaff7350deeb73cbbd535b6
CPU threads: 1; OS: Windows 10.0 Build 17763; UI render: Skia/Raster; VCL: win
Locale: hu-HU (en_US); UI: en-US
Calc: threaded
Comment 1 Gabor Kelemen (allotropia) 2021-10-11 06:48:17 UTC
Created attachment 175639 [details]
The example file in Calc and Excel side by side
Comment 2 Gabor Kelemen (allotropia) 2021-10-11 06:48:34 UTC
Created attachment 175640 [details]
A similar example file made from scratch
Comment 3 Gabor Kelemen (allotropia) 2021-10-11 06:49:00 UTC
Created attachment 175641 [details]
The similar example file works fine when saved as xlsx
Comment 4 Xisco Faulí 2021-10-22 09:25:58 UTC
Reproduced in

Version: 7.3.0.0.alpha0+ / LibreOffice Community
Build ID: ea65215855462e5e48f7a3a78724c38b5fc0e4d1
CPU threads: 4; OS: Linux 5.10; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 5 Gabor Kelemen (allotropia) 2021-12-22 14:11:51 UTC
Created attachment 177094 [details]
For reference: attachment 170421 [details] modified in Excel

Doing the same in Excel works fine when opened in Calc.
Comment 6 Samuel Mehrbrodt (allotropia) 2021-12-22 19:28:23 UTC
*** Bug 145058 has been marked as a duplicate of this bug. ***
Comment 7 Commit Notification 2021-12-22 19:35:00 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/b85e99950dc4584160512cffec303827c02f2d15

tdf#145057 Fix saving color filter when multiple data ranges in sheet

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2021-12-23 10:05:24 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "libreoffice-7-3":

https://git.libreoffice.org/core/commit/5de1c78ba793bd53961e5bb4ec5fe4c5b6828224

tdf#145057 Fix saving color filter when multiple data ranges in sheet

It will be available in 7.3.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.