Bug 145073 - Editing an email address corrupts the cell data
Summary: Editing an email address corrupts the cell data
Status: RESOLVED DUPLICATE of bug 72266
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.2.1.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-10-11 13:19 UTC by Matteo Croce
Modified: 2021-10-11 13:35 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Text wrongly appended to the end (463.31 KB, video/mp4)
2021-10-11 13:19 UTC, Matteo Croce
Details
Cells gets cleared (602.27 KB, video/mp4)
2021-10-11 13:19 UTC, Matteo Croce
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matteo Croce 2021-10-11 13:19:23 UTC
Created attachment 175668 [details]
Text wrongly appended to the end

Editing a cell containing an email address from the formula bar corrupts it.
The corruption is somewhat random regarding if the new text is added in the middle or in the beginning.

I attach two videos of what happens.
This bug exists from several major versions.
Comment 1 Matteo Croce 2021-10-11 13:19:54 UTC
Created attachment 175669 [details]
Cells gets cleared
Comment 2 m.a.riosv 2021-10-11 13:35:57 UTC
Because it's interpreted as a hyperlink, you can use [Ctrl+K] or Menu/Insert/Hyperlink to edit as you like.

*** This bug has been marked as a duplicate of bug 72266 ***