Bug 145090 - LO Calc Crash with drop-down-menu (GTK3)
Summary: LO Calc Crash with drop-down-menu (GTK3)
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.2.1.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard: target:7.4.0 target:7.3.0.2 target:7.2.6
Keywords: bibisected, bisected, regression, wantBacktrace
Depends on:
Blocks:
 
Reported: 2021-10-12 10:36 UTC by peter
Modified: 2022-01-11 09:30 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
sheet which indicates the crash (8.08 KB, application/vnd.oasis.opendocument.spreadsheet)
2021-10-12 10:37 UTC, peter
Details
Info from about LO (45.47 KB, image/png)
2021-10-13 09:14 UTC, peter
Details
LO crash info (15.96 KB, image/png)
2021-11-27 17:19 UTC, peter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description peter 2021-10-12 10:36:00 UTC
Description:
I built a sheet with a former version of LOCalc (5...) with some drop-down-menus in an table and some tables. If I change the tables with the newest version of LOCalc LO crashes.

Steps to Reproduce:
1.create 2 tables
2.put a drop-down-menu with some components in a table
3.alternate between the tables -> LO crashes

Actual Results:
see above

Expected Results:
LO crashes


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
no crash
Comment 1 peter 2021-10-12 10:37:44 UTC
Created attachment 175687 [details]
sheet which indicates the crash
Comment 2 peter 2021-10-12 10:45:55 UTC
The crash does not happen if LOCalc is in the Design Mode.
(Tools->forms->Design Mode)
Comment 3 Timur 2021-10-12 18:49:49 UTC
Please write your Help-About. Maybe bug 144037.
Comment 4 Xisco Faulí 2021-10-13 07:51:00 UTC
Thanks for reporting this issue.
Could you please paste the info from Help - about LibreOffice ?

I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' once the information has been provided
Comment 5 peter 2021-10-13 09:14:36 UTC
Created attachment 175713 [details]
Info from about LO

Here is the info.
Comment 6 Julien Nabet 2021-10-13 19:40:03 UTC
How did you install LO? From official TDF website, from distrib repo, other?
What's your distribution and which version do you use?
Comment 7 peter 2021-10-14 12:01:52 UTC
I installed LO from distrib repo. My distribution is Siduction which is based on Debian. The kernel version is 5.14.10-1-siduction-amd64.
Comment 8 peter 2021-11-26 13:16:59 UTC
Also with the actual version 7.2.3.2 the problem exist.
Comment 9 Julien Nabet 2021-11-26 16:32:35 UTC
When you indicate "3.alternate between the tables", do you just mean:
- click on Tabelle2 sheet
- click on Tabelle1 sheet
- click on Tabelle2 sheet
etc.
?
If not, could you attach a screencast so we can try to reproduce this?
On which env are you? gtk3, kde, other?

(I'm on Debian testing and by default it uses gtk3)

You can also to retrieve a backtrace (also called "stacktrace", not the same as "strace"), see https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#GNU.2FLinux:_How_to_get_a_backtrace
Comment 10 peter 2021-11-27 17:19:44 UTC
Created attachment 176537 [details]
LO crash info
Comment 11 peter 2021-11-27 17:20:54 UTC
Yes, when I am on Tabelle2 and switch to Tabelle1 and go back to Tabelle2 LO crashes. Then the LO-crash-info is displayed. (see attachment)

My system info:
System:    Host: master Kernel: 5.15.5-1-siduction-amd64 x86_64 bits: 64 compiler: gcc v: 11.2.0 Desktop: Xfce 4.16.0 Distro: siduction - xfce base: Debian GNU/Linux bookworm/sid

My installed gtk packages:
dpkg -l | grep gtk
ii  gir1.2-gtk-3.0:amd64                             3.24.30-3                             amd64        GTK graphical user interface library -- gir bindings
ii  gstreamer1.0-gtk3:amd64                          1.18.5-1+b1                           amd64        GStreamer plugin for GTK+3
ii  gtk-update-icon-cache                            3.24.30-3                             amd64        icon theme caching utility
ii  gtk2-engines-pixbuf:amd64                        2.24.33-2                             amd64        pixbuf-based theme for GTK 2
ii  gtk2-engines-xfce                                3.2.0-4                               amd64        GTK+-2.0 theme engine for Xfce
ii  libaiksaurusgtk-1.2-0c2a                         1.2.1+dev-0.12-7                      amd64        graphical interface to the Aiksaurus toolkit (library)
ii  libcanberra-gtk0:amd64                           0.30-8                                amd64        GTK+ helper for playing widget event sounds with libcanberra
ii  libcanberra-gtk3-0:amd64                         0.30-8                                amd64        GTK+ 3.0 helper for playing widget event sounds with libcanberra
ii  libcheese-gtk25:amd64                            41.1-1                                amd64        tool to take pictures and videos from your webcam - widgets
ii  libclutter-gtk-1.0-0:amd64                       1.8.4-4+b1                            amd64        Open GL based interactive canvas library GTK+ widget
ii  libdbusmenu-gtk3-4:amd64                         18.10.20180917~bzr492+repack1-2+b1    amd64        library for passing menus over DBus - GTK-3+ version
ii  libdbusmenu-gtk4:amd64                           18.10.20180917~bzr492+repack1-2+b1    amd64        library for passing menus over DBus - GTK-2+ version
ii  libgarcon-gtk3-1-0:amd64                         4.16.1-1                              amd64        menu library for Xfce (GTK3 library)
ii  libgtk-3-0:amd64                                 3.24.30-3                             amd64        GTK graphical user interface library
ii  libgtk-3-bin                                     3.24.30-3                             amd64        programs for the GTK graphical user interface library
ii  libgtk-3-common                                  3.24.30-3                             all          common files for the GTK graphical user interface library
ii  libgtk2.0-0:amd64                                2.24.33-2                             amd64        GTK graphical user interface library - old version
ii  libgtk2.0-common                                 2.24.33-2                             all          common files for the GTK graphical user interface library
ii  libgtk3-perl                                     0.038-1                               all          Perl bindings for the GTK+ graphical user interface library
ii  libgtkglext1:amd64                               1.2.0-11                              amd64        OpenGL Extension to GTK+ (shared libraries)
ii  libgtkglextmm-x11-1.2-0v5:amd64                  1.2.0-8+b1                            amd64        C++ bindings for GtkGLExt (Shared libraries)
ii  libgtkhotkey1:amd64                              0.2.1-6+b2                            amd64        Gtk hotkey shared library
ii  libgtkmm-2.4-1v5:amd64                           1:2.24.5-4+b1                         amd64        C++ wrappers for GTK+ 2 (shared libraries)
ii  libgtkmm-3.0-1v5:amd64                           3.24.5-1                              amd64        C++ wrappers for GTK+ (shared libraries)
ii  libgtksourceview-3.0-1:amd64                     3.24.11-2+b1                          amd64        shared libraries for the GTK+ syntax highlighting widget
ii  libgtksourceview-3.0-common                      3.24.11-2                             all          common files for the GTK+ syntax highlighting widget
ii  libjavascriptcoregtk-1.0-0:amd64                 2.4.11-4+b1                           amd64        JavaScript engine library from WebKitGTK+
ii  libjavascriptcoregtk-4.0-18:amd64                2.34.2-1                              amd64        JavaScript engine library from WebKitGTK
ii  libreoffice-gtk3                                 1:7.2.3-1                             amd64        office productivity suite -- GTK+ 3 integration
ii  libwebkit2gtk-4.0-37:amd64                       2.34.2-1                              amd64        Web content engine library for GTK
ii  libwebkitgtk-1.0-0:amd64                         2.4.11-4+b1                           amd64        Web content engine library for GTK+
ii  libwxgtk3.0-gtk3-0v5:amd64                       3.0.5.1+dfsg-2+b1                     amd64        wxWidgets Cross-platform C++ GUI toolkit (GTK 3 runtime)
ii  lightdm-gtk-greeter                              2.0.8-2+b1                            amd64        simple display manager (GTK+ greeter)
ii  pinentry-gtk2                                    1.1.0-4                               amd64        GTK+-2-based PIN or pass-phrase entry dialog for GnuPG
ii  xdg-desktop-portal-gtk                           1.10.0-3                              amd64        GTK+/GNOME portal backend for xdg-desktop-portal
Comment 12 Julien Nabet 2021-11-27 18:07:35 UTC
I gave a new try on pc Debian x86-64 with master sources updated today or with LO Debian package 7.2.2.2 and gen rendering, I don't reproduce this.

I can't help here => uncc myself
Comment 13 peter 2021-11-28 11:09:46 UTC
Hi Julien,
have you tested it with my localc sheet?
Comment 14 peter 2021-12-01 12:47:42 UTC
I reinstalled LO and now I found the problem:
After an installation of the package libreoffice-gtk3 I have the issue. Without this package LO works fine.
Comment 15 raal 2021-12-22 16:31:57 UTC
I can reproduce the crash with Version: 7.4.0.0.alpha0+ / LibreOffice Community
Build ID: 40487d9c81c69c4e5ee1621e53c8162ae33c80b2
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: cs-CZ (cs_CZ.UTF-8); UI: en-US
Calc: threaded
Comment 16 raal 2021-12-22 17:04:16 UTC
This seems to have begun at the below commit.
Adding Cc: to Noel Grandin; Could you possibly take a look at this one?
Thanks
 157f236d1084aba087e3dcd66d8cfac5e95a7a91 is the first bad commit
commit 157f236d1084aba087e3dcd66d8cfac5e95a7a91
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Sat May 29 14:40:53 2021 +0200

    source sha:8d485ec0cd35ee1ae7684f2b6ca96c0f0c6f9dac

https://git.libreoffice.org/core/+/8d485ec0cd35ee1ae7684f2b6ca96c0f0c6f9dac
   IsDisposed->isDisposed in vcl/../window
Comment 17 Noel Grandin 2021-12-23 07:50:13 UTC
@raal I can't reproduce this on master, do you perhaps have a backtrace?
Comment 18 Xisco Faulí 2021-12-23 10:38:51 UTC
(In reply to Noel Grandin from comment #17)
> @raal I can't reproduce this on master, do you perhaps have a backtrace?

I can reproduce it in

Version: 7.4.0.0.alpha0+ / LibreOffice Community
Build ID: 57ad86fec9e5b4981332392bdb5c5a1f5e468bfe
CPU threads: 4; OS: Linux 5.10; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

Steps:
1. Open the attached document
2. Click on the drop-down menu
3. Click on Tabelle2
4. Click On tabelle1
5. Click on Tabelle2

-> Crash
Comment 19 Xisco Faulí 2021-12-23 10:44:25 UTC
This is only happening with GTK3, not with GEN

@Caolán, I thought you might also be interested in this issue
Comment 20 raal 2021-12-23 11:53:36 UTC
(In reply to Noel Grandin from comment #17)
> @raal I can't reproduce this on master, do you perhaps have a backtrace?

Unfortunately, it doesn't crash with dbg build
Comment 21 Commit Notification 2021-12-25 08:29:57 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/3454055d4da3326540905fc69626b934d5aa0744

tdf#145090 LO Calc Crash with drop-down-menu

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 22 Commit Notification 2021-12-28 12:36:29 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "libreoffice-7-3":

https://git.libreoffice.org/core/commit/0c183add008e3604711d1995716cdcffc0881dc6

tdf#145090 LO Calc Crash with drop-down-menu

It will be available in 7.3.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 23 Xisco Faulí 2022-01-11 09:29:15 UTC
Verified in

Version: 7.4.0.0.alpha0+ / LibreOffice Community
Build ID: bf883027ee62ece0844730572305094f53daa521
CPU threads: 4; OS: Linux 5.10; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Noel, thanks for fixing this issue!!
Comment 24 Commit Notification 2022-01-11 09:30:52 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "libreoffice-7-2":

https://git.libreoffice.org/core/commit/02e7628f603959d15c0f1b8a8d2c17b1550479b3

tdf#145090 LO Calc Crash with drop-down-menu

It will be available in 7.2.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.