Bug 145107 - Installer definitely should ask (have an option) for bundled fonts installation
Summary: Installer definitely should ask (have an option) for bundled fonts installation
Status: RESOLVED DUPLICATE of bug 91886
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
7.2.1.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-10-13 09:06 UTC by cyr.k
Modified: 2021-10-13 11:39 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description cyr.k 2021-10-13 09:06:54 UTC
Description:
LibreOffice automatically installs a bunch of fonts, including Roboto, system-wide, that a lot of users may not want to have installed.

In particular: bundled Roboto fonts cause the text rendering in Firefox on a lot of sites (YouTube.com) to be much inferior than the font that would otherwise be remote-downloaded through the regular CSS embedding. There are other similar issues.

Steps to Reproduce:
1. Install LibreOffice
2. There are many new fonts in Windows Control Panel

Actual Results:
These fonts are then used as local fonts on youtube.com etc and they have rendering issues.

Expected Results:
I do not want any fonts silently installed to my system.


Reproducible: Always


User Profile Reset: No



Additional Info:
Use any current Firefox with WebRender to see the rendering issues.
Comment 1 Roman Kuznetsov 2021-10-13 11:39:47 UTC

*** This bug has been marked as a duplicate of bug 91886 ***