Bug 145319 - Impress ignores image crop parameters created on another machine
Summary: Impress ignores image crop parameters created on another machine
Status: RESOLVED DUPLICATE of bug 112538
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
7.2.2.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-10-26 06:04 UTC by Mateusz Łącki
Modified: 2021-10-27 16:32 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
this is what the second slide should look like (1.18 MB, image/png)
2021-10-26 06:07 UTC, Mateusz Łącki
Details
this is what it looks on mac (2.15 MB, image/png)
2021-10-26 06:09 UTC, Mateusz Łącki
Details
test file (1.49 MB, application/vnd.oasis.opendocument.presentation)
2021-10-26 06:09 UTC, Mateusz Łącki
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mateusz Łącki 2021-10-26 06:04:56 UTC
Description:
Impress seems to partially the "crop window".  Specifically LO Impress file created in 7.2.2.2 containing a cropped image is lated opened on LO Impress 7.2.2.2 on macOS.  The enclosed screenshot indicate that the test_linux.odp file right after being open on mac looks differently - the image is shifted.

This is a major bug, because it is impossible to show the presentation created on one computer on the other computer (extremely common scenario during organized events).

Steps to Reproduce:
1. open test_linux.odp on Linux and Mac, they should look different.
Or:
1.insert a figure into Impress on Linux, crop it from all 4 sides.
2. Open the above presentation on Mac laptop.
3.

Actual Results:
The image crop window should be interpreted differently by Mac and Linux versions of LO.

Expected Results:
It should look the same.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
The Mac computer has no hardware acceleration. The Linux desktop has.

Version: 7.2.2.2 / LibreOffice Community
Build ID: 20(Build:2)
CPU threads: 4; OS: Linux 5.13; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Ubuntu package version: 1:7.2.2-0ubuntu0.21.10.1
Calc: threaded

Version: 7.2.2.2 / LibreOffice Community
Build ID: 02b2acce88a210515b4a5bb2e46cbfb63fe97d56
CPU threads: 8; OS: Mac OS X 10.16; UI render: default; VCL: osx
Locale: en-US (en_PL.UTF-8); UI: en-US
Calc: threaded
Comment 1 Mateusz Łącki 2021-10-26 06:07:59 UTC
Created attachment 175918 [details]
this is what the second slide should look like
Comment 2 Mateusz Łącki 2021-10-26 06:09:17 UTC
Created attachment 175919 [details]
this is what it looks on mac

the filename in the window title is different - I have used "save as" right before the screenshot
Comment 3 Mateusz Łącki 2021-10-26 06:09:49 UTC
Created attachment 175920 [details]
test file
Comment 4 Telesto 2021-10-26 15:26:15 UTC
Likely caused by screen DPI differences.. see for example bug 112538
Comment 5 Mateusz Łącki 2021-10-26 16:45:40 UTC
I have read that bugreport. Indeed it looks related, how can I test this is the case?
I am not sure what is meant by treating PNGs without PHYsical pixel dimension as "garbage in-garbage out". When I paste the PNG into the presentationand it is presented in _some_ way, the Impress should fill in any missing parameters based on the way the image is currently shown, save it to the file, and on every other machine it should be appear the same way.
Comment 6 Telesto 2021-10-26 17:00:51 UTC
(In reply to Mateusz Łącki from comment #5)
> I have read that bugreport. Indeed it looks related, how can I test this is
> the case?
> I am not sure what is meant by treating PNGs without PHYsical pixel
> dimension as "garbage in-garbage out".

Well the image in the example file has no embedded dpi resolution (I renamed the ODP to zip & look inside the image folder. opened the image in my case in Irfan View and opened looked at the image information..

 When I paste the PNG into the
> presentationand it is presented in _some_ way, the Impress should fill in
> any missing parameters based on the way the image is currently shown, save
> it to the file, and on every other machine it should be appear the same way.

Well it should, but it doesn't :-(
Comment 7 Timur 2021-10-27 15:18:53 UTC
I repeat what I wrote in bug 141950: see bug 102296, bug 112538, bug 115808, this could be a duplicate.
And if not sure, still mark duplicate because it's better visible and it still can be tested if ever fixed (or "when fixed").
Also see meta bug 116082 and Depends on bugs.
Comment 8 Telesto 2021-10-27 16:32:59 UTC

*** This bug has been marked as a duplicate of bug 112538 ***