Bug 145329 - [CRASH] Filtering by Background color freezes LO Calc
Summary: [CRASH] Filtering by Background color freezes LO Calc
Status: RESOLVED DUPLICATE of bug 142420
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.2.2.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: KDE AutoFilter-Color
  Show dependency treegraph
 
Reported: 2021-10-26 17:19 UTC by Rafael Lima
Modified: 2021-10-26 18:24 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Sample ODS file (225.31 KB, application/vnd.oasis.opendocument.spreadsheet)
2021-10-26 17:19 UTC, Rafael Lima
Details
Video reproducing the bug (1.57 MB, video/mp4)
2021-10-26 17:21 UTC, Rafael Lima
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rafael Lima 2021-10-26 17:19:59 UTC
Created attachment 175936 [details]
Sample ODS file

With the attached file, whenever I apply the second filter LO Calc freezes.

Steps to reproduce:
1) Open the attached sample ODS file.
2) Follow the steps I show in the attached video.

When I click the second filter, LO freezes and there's no way to use it anymore, so I have to kill the process.
Comment 1 Rafael Lima 2021-10-26 17:21:18 UTC
Created attachment 175937 [details]
Video reproducing the bug

Here's the video showing how to reproduce the bug. Notice that after I click the second filter, LO freezes.
Comment 2 Rafael Lima 2021-10-26 17:25:30 UTC
System info:

Version: 7.2.2.2 / LibreOffice Community
Build ID: 20(Build:2)
CPU threads: 16; OS: Linux 5.11; UI render: default; VCL: kf5 (cairo+xcb)
Locale: pt-BR (pt_BR.UTF-8); UI: en-US
Ubuntu package version: 1:7.2.2~rc2-0ubuntu0.21.04.1~lo1
Calc: threaded
Comment 3 Rainer Bielefeld Retired 2021-10-26 17:38:06 UTC
NOT reproducible with Installation of Version:7.2.1.2 (x64); Build ID: 87b77fad49947c1441b67c559c339af8f3517e22; CPU threads: 12; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win; Locale: de-DE (de_DE); UI: de-DE; Calc: threaded.

Started with 7.2.2? I'm doing something wrong? Linux related? Something else?
Comment 4 Julien Nabet 2021-10-26 18:24:25 UTC

*** This bug has been marked as a duplicate of bug 142420 ***