Bug 145396 - The line indicating deleted content keeps present after rejecting all changes (until scroll)
Summary: The line indicating deleted content keeps present after rejecting all changes...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.3.0.0 alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.5.0 target:7.4.0.2 target:7.3.6
Keywords: bibisected, bisected, regression
: 148992 149994 (view as bug list)
Depends on:
Blocks: Track-Changes-Table
  Show dependency treegraph
 
Reported: 2021-10-30 06:47 UTC by Telesto
Modified: 2022-07-26 09:59 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Bibisect log (2.74 KB, text/plain)
2021-10-30 06:56 UTC, Telesto
Details
Sample Document (8.98 KB, application/vnd.oasis.opendocument.text)
2021-11-02 07:24 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2021-10-30 06:47:18 UTC
Description:
The showing a change keeps present after rejecting all changes (until scroll)

Steps to Reproduce:
1. Open attachment 175689 [details]
2. Edit -> Track Changes -> Reject all (notice the line still being present at the left side of the table
3. Scroll -> now it updates

Actual Results:
Middle row still has a line at the right side

Expected Results:
No so 


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 93115d2c54d645bcf2f80fde325e3ede39dee4d5
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 1 Telesto 2021-10-30 06:48:22 UTC
Still OK in
Version: 7.2.1.0.0+ (x64) / LibreOffice Community
Build ID: 8fdbb8aed1b48734a717d5f98ada566de7204605
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 2 Telesto 2021-10-30 06:56:59 UTC
Created attachment 176017 [details]
Bibisect log

Bisected to
author	Luboš Luňák <l.lunak@collabora.com>	2021-08-09 12:44:40 +0200
committer	Luboš Luňák <l.lunak@collabora.com>	2021-09-08 10:31:03 +0200
commit b9c2207e1b5247b4d3184b137be9a75a4b8c6c37 (patch)
tree e1e16272c48b735d7e1ffa69a6b7f318ab2ca685
parent 89a282e874a706a6f7265218f476e3948dbaa10c (diff)
avoid repeated writer layout calls with tiled rendering
My next commit will disable idle paints for tile rendering, as they
do nothing in that case (or at least that should be the case).
But this code causes an infinite loop with idle layout timer,
because painting resets the SwViewShellImp paint region, which is
not performed if painting is done only later by idle rendering.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=b9c2207e1b5247b4d3184b137be9a75a4b8c6c37
Comment 3 Telesto 2021-10-30 06:58:43 UTC
Adding CC: to Luboš Luňák
Comment 4 Rainer Bielefeld Retired 2021-11-02 07:24:17 UTC
Created attachment 176072 [details]
Sample Document

Well, regarding Change Tracking I see very much behavior without anylogic.And from LibO version to LibOversion behavior changes a little.

11. With LibO 6.4.7. open mytest20.odt
12. Make sure that Record and Show changes is active
13. Click into cell C3 with "3"
14. Click on icon 'Delete Row'
   » Row disappears
     No vertical line as indicator of change at the left   😥
     No change listed in ˋEdit → Track Changes → Manageˊ   😥

Redo Test with LibO 7.2.1.2:
In step 14 everything ist as expected.                              👌 
but
15. Uncheck ˋEdit → Track Changes → Showˊ
    » Expected: Line simply disapears
      Actual:   Empty line stays, only contents of C3 
                will no longerbe shown.                    😥 

Trying with 7.3.0.0 the problem of Step15 has become repaired       👌 
But now LibO shows problem as reported.

So it might be useful to observe changes from version to version concerning this change tracking.
Comment 5 Rainer Bielefeld Retired 2021-11-02 07:37:17 UTC
And I can confirm reported effect with 7.3.0.0 (more or less). I see no update in step 3 when scrolling, I have to click outside the table.
Comment 6 Xisco Faulí 2022-05-03 12:28:33 UTC
Dear László Németh,
This bug has been in ASSIGNED status for more than 3 months without any
activity. Resetting it to NEW.
Please assign it back to yourself if you're still working on this.
Comment 7 Luboš Luňák 2022-07-21 12:11:43 UTC
*** Bug 149994 has been marked as a duplicate of this bug. ***
Comment 8 Luboš Luňák 2022-07-21 12:15:44 UTC
*** Bug 148992 has been marked as a duplicate of this bug. ***
Comment 9 Commit Notification 2022-07-21 14:47:19 UTC
Luboš Luňák committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/9dff8edf97f454f24a40acbed4a9297816f91da6

Revert "avoid repeated writer layout calls with tiled rendering" (tdf#145396)

It will be available in 7.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2022-07-26 09:58:04 UTC
Luboš Luňák committed a patch related to this issue.
It has been pushed to "libreoffice-7-4":

https://git.libreoffice.org/core/commit/fc435d88f6d700aeb5e5f43f41ff659b98df0a95

Revert "avoid repeated writer layout calls with tiled rendering" (tdf#145396)

It will be available in 7.4.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2022-07-26 09:59:16 UTC
Luboš Luňák committed a patch related to this issue.
It has been pushed to "libreoffice-7-3":

https://git.libreoffice.org/core/commit/e61e77481174692d5be72962f6f029e6f4e2e8d9

Revert "avoid repeated writer layout calls with tiled rendering" (tdf#145396)

It will be available in 7.3.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.