Bug 145541 - Opening document from Firefox or Thunderbird shows unnecessary Document is read-only dialog
Summary: Opening document from Firefox or Thunderbird shows unnecessary Document is re...
Status: RESOLVED DUPLICATE of bug 143971
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
7.2.2.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-11-04 13:50 UTC by Esa Ristilä
Modified: 2021-11-04 14:41 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Esa Ristilä 2021-11-04 13:50:04 UTC
Description:
When opening document from Firefox link or Thunderbird attachment LibreOffice presents dialog:

"Document file 'foo.xlsx' is read-only.

Open read-only or select Notify to open read-only and get notified when the document becomes editable."

With buttons to open read-only, notify or cancel.

These files are temporary and as such will not become editable. The dialog is waste of user's time, the notification on top of the document window is quite sufficient.

Steps to Reproduce:
1. Click Office attachment from Thunderbird or click link to an Office file in Firefox.
2. Open the file in LibreOffice.


Actual Results:
LibreOffice presents an document is read-only dialog.

Expected Results:
No read-only dialog should be presented.


Reproducible: Always


User Profile Reset: No



Additional Info:
This bug appeared around 7.2 release.
Comment 1 Mike Kaganski 2021-11-04 14:41:56 UTC

*** This bug has been marked as a duplicate of bug 143971 ***