Bug 145650 - LibreOffice Start app (soffice.exe) shows visual clipping on the side categories
Summary: LibreOffice Start app (soffice.exe) shows visual clipping on the side categories
Status: RESOLVED DUPLICATE of bug 119447
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.3.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-11-12 22:19 UTC by Matt K
Modified: 2022-07-31 22:41 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
shows screen clipping on left side (86.13 KB, image/png)
2021-11-12 22:20 UTC, Matt K
Details
Screenshot shows difference between LibO 7.2 and LibO7.3 (220.18 KB, image/png)
2021-11-13 07:40 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matt K 2021-11-12 22:19:31 UTC
Description:
See screenshot

Steps to Reproduce:
1. Run soffice.exe
2. Observe screen clipping

Actual Results:
screen clipping observed on left side

Expected Results:
No screen clipping, perhaps instead shows a scrollbar


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.3.0.0.alpha1+ (x64) / LibreOffice Community
Build ID: 29f08453059c308e3ce076c8689e48b19f84c026
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: threaded
Comment 1 Matt K 2021-11-12 22:20:54 UTC
Created attachment 176222 [details]
shows screen clipping on left side
Comment 2 Rainer Bielefeld Retired 2021-11-13 07:40:42 UTC
Created attachment 176225 [details]
Screenshot shows difference between LibO 7.2 and LibO7.3

REPRODUCIBLE with Server Installation of Version7.3.0.0.alpha1+ (x64)  |   Build ID b8d17d754830ab57099dcdfa72a96bfad404ab1a  |  CPU threads: 12; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win  |  Locale: de-DE (de_DE); UI: de-DE  |  Calc: CL  |  Special devUserProfile

Decreasing height of LibO Start Page window is limited, in 7.2 minimum height is calculated correctly to avoid clipping. With 7.3 base will be clipped.

I did not find a DUP of this one
Comment 3 Rainer Bielefeld Retired 2021-11-13 07:41:02 UTC
NEW due to comment 2
Comment 4 Matt K 2022-07-27 19:25:26 UTC
Unable to repro using:

Version: 7.5.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 4d42aeae86253e167facb1adfddd0c9976b7801a
CPU threads: 12; OS: Windows 10.0 Build 22000; UI render: Skia/Vulkan; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: CL

This may only repro on smaller screens.
Comment 5 Telesto 2022-07-30 20:18:02 UTC
(In reply to Matt K from comment #4)
> Unable to repro using:
> 
> Version: 7.5.0.0.alpha0+ (x64) / LibreOffice Community
> Build ID: 4d42aeae86253e167facb1adfddd0c9976b7801a
> CPU threads: 12; OS: Windows 10.0 Build 22000; UI render: Skia/Vulkan; VCL:
> win
> Locale: en-US (en_US); UI: en-US
> Calc: CL
> 
> This may only repro on smaller screens.

Maybe fixed by https://gerrit.libreoffice.org/c/core/+/134867 ?
Comment 6 Matt K 2022-07-31 22:41:47 UTC
(In reply to Telesto from comment #5)
> Maybe fixed by https://gerrit.libreoffice.org/c/core/+/134867 ?

Yes, I checked out the build before that fix and after it, and it only repros in the "before" checkout.  Resolving as a duplicate of the linked change's bug.

*** This bug has been marked as a duplicate of bug 119447 ***