Bug 145694 - Fontwork doesn't show 'soft edge' and glow effects side panel
Summary: Fontwork doesn't show 'soft edge' and glow effects side panel
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
7.2.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.3.0
Keywords: bibisected, regression
Depends on:
Blocks:
 
Reported: 2021-11-15 10:50 UTC by Telesto
Modified: 2021-11-18 16:08 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot (149.39 KB, image/png)
2021-11-15 14:15 UTC, Telesto
Details
screensot with build 864cbd8 (186.54 KB, image/png)
2021-11-15 14:34 UTC, Kevin Suo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2021-11-15 10:50:51 UTC
Description:
Fontwork not supporting 'soft edge' and glow?

Steps to Reproduce:
1. Open Draw/Impress & Insert a fontwork
2. No option for Glow or soft edge

Actual Results:
Glow or soft edge

Expected Results:
No clue; I kind of would expect this for Fontwork too. But well not knowing the background for it not being available


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.3.0.0.alpha1+ (x64) / LibreOffice Community
Build ID: 73334560b2dd2d60ac58d2cc2b1a5295490b03e1
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 1 Telesto 2021-11-15 10:52:22 UTC
It's present in
Version: 7.1.0.0.alpha0+ (x64)
Build ID: 47fda617fc4dad8273919227ca45ea3b8b61aea1
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: nl-NL
Calc: CL
Comment 2 Telesto 2021-11-15 10:54:05 UTC
@Mike
Is glow & soft edge removed from fontwork on purpose? It doesn't show anymore in the sidebar
Comment 3 Mike Kaganski 2021-11-15 11:01:54 UTC
(In reply to Telesto from comment #1)
> It's present in
> Version: 7.1.0.0.alpha0+ (x64)
> Build ID: 47fda617fc4dad8273919227ca45ea3b8b61aea1

This means it wants to be bibisected. I have no idea who did that and for what.
Comment 4 Kevin Suo 2021-11-15 11:19:08 UTC
Could you please provide a screenshot showing where the Glow or soft edge is in  7.1.0.0.alpha0+? I tried to bibisect but I do not find them.
Comment 5 Telesto 2021-11-15 14:15:53 UTC
Created attachment 176259 [details]
Screenshot
Comment 6 Kevin Suo 2021-11-15 14:34:12 UTC
Created attachment 176260 [details]
screensot with build 864cbd8

But I do see this fontwork with the most updated master build 864cbd8 as of today. Am I missing something??
Comment 7 Kevin Suo 2021-11-15 14:36:51 UTC
Oh I see, it's on the side bar...
Comment 8 Kevin Suo 2021-11-15 15:08:54 UTC
Bibisected to range: ac8a456d7a6c1bf5b1574eeda8ea2ac41a9b32bc..49066fcc969167e0744407b064ecb4b66c059705

Most lilely caused by
commit 903902f826129705f1fafc5583a13be645e145b5
Author: Szymon Kłos <szymon.klos@collabora.com>
Date:   Wed Jan 27 14:34:19 2021 +0100

    Introduce Fontwork context

and its follow-up commit:
commit a49206fd70e72023493fdd9ecea4cd58f9a2aee6
Author: Szymon Kłos <szymon.klos@collabora.com>
Date:   Wed Jan 27 10:58:12 2021 +0100

    fontwork: add sidebar panel

Adding Szymon Kłos to cc: Would you please take a look? Is the 'soft edge' and glow effects, as previously shown on the side bar, removed by your commits intentionally, or by mistake?
Comment 9 Szymon Kłos 2021-11-16 08:01:52 UTC
I see, this was by mistake. I ported my patch introducing fontwork context from older branch where soft edge and glow was not present I think. We have to add that context to these panels.
Comment 10 Szymon Kłos 2021-11-16 08:10:55 UTC
https://gerrit.libreoffice.org/c/core/+/125270
Comment 11 Commit Notification 2021-11-16 09:54:28 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/1430d7670070606de41bd954835e55a71d88875b

tdf#145694 sidebar: add glow and soft edge panel for fontwork

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Szymon Kłos 2021-11-16 09:54:49 UTC
fix needs to clear user config to be applied I think