Bug 145704 - Drop-downs do not recognize mouse button #1 to select from list
Summary: Drop-downs do not recognize mouse button #1 to select from list
Status: RESOLVED DUPLICATE of bug 144037
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
7.2.1.2 release
Hardware: x86-64 (AMD64) FreeBSD
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Qt5
  Show dependency treegraph
 
Reported: 2021-11-15 17:24 UTC by Matt Adams
Modified: 2021-11-18 20:07 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matt Adams 2021-11-15 17:24:25 UTC
Description:
Drop-downs throughout the UI (either in the toolbar, or in a drop-down found in a cell via Calc's data validation tool) refuse to recognize mouse button #1 to select an item from the list. I can open the drop-down using button #1 but can't select from the list using the same button.

Selecting and then hitting Enter seems to accept a selected value.

I don't know why this is happening but it seems to have started when I moved to 7.2.1.2.

Steps to Reproduce:
1. Open drop-down from anywhere in Libreoffice (either toolbar or in Calc)
2. Navigate to desired value
3. Click with mouse button #1

Actual Results:
Nothing happens. Value selection is ignored.

Expected Results:
Expected value to be selected WITHOUT having to resort to using Enter on the keyboard.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 7.2.1.2 / LibreOffice Community
Build ID: 20(Build:2)
CPU threads: 12; OS: FreeBSD 12.2; UI render: default; VCL: qt5 (cairo+xcb)
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 1 Roman Kuznetsov 2021-11-18 19:50:29 UTC
Looks like the bug 144037 but I'm not sure

Matt< could you please update your LibreOffice to 7.2.2?
Comment 2 phd 2021-11-18 20:07:50 UTC
@Roman Kuznetsov
Yes, the description matches my report perfectly: #144742, which is also a duplicate of #144037. Affected version also matches perfectly.

*** This bug has been marked as a duplicate of bug 144037 ***