Bug 145719 - ODT import/Changes In Margin mode: recognize text moving
Summary: ODT import/Changes In Margin mode: recognize text moving
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.1.8.1 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.3.0 inReleaseNotes
Keywords:
Depends on:
Blocks: tracked-changes-in-margin
  Show dependency treegraph
 
Reported: 2021-11-16 14:59 UTC by NISZ LibreOffice Team
Modified: 2021-12-29 23:11 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
ODT test file (10.59 KB, application/vnd.oasis.opendocument.text)
2021-11-19 11:45 UTC, László Németh
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2021-11-16 14:59:46 UTC
Description:
Text moving is only recognized in simple cases, but not when the moved text was modified later.

Steps to Reproduce:
1.	Open the attached file.
2.	See that the string is displayed at both the original position, as well as the new position.
3.	Save, and reload the file.


Actual Results:
The change is not visible.

Expected Results:
Should be the change visible with green after the move.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.3.0.0.alpha1+ (x64) / LibreOffice Community
Build ID: a0a38b88dc3a61d212d784f41a27f97d9c2d7f32
CPU threads: 4; OS: Windows 10.0 Build 19042; UI render: default; VCL: win
Locale: hu-HU (hu_HU); UI: hu-HU
Calc: threaded
Comment 1 Xisco Faulí 2021-11-16 16:15:08 UTC
I believe this is a duplicate of bug 145720

*** This bug has been marked as a duplicate of bug 145720 ***
Comment 2 László Németh 2021-11-19 11:39:47 UTC
Xisco: sorry, I reuse this report for an existing problem, as intended originally.
Comment 3 László Németh 2021-11-19 11:44:37 UTC
ODT import and  Changes In Margin mode store redline text content in a hidden section, so text moving is not recognized without accessing that.

Test:

A) open the attached ODT document. Text moving is not recognized.

B) Set Changes In Margin mode e.g. by Deletions In Margin menu item of Show Changes button of the Track Changes toolbar. Cut a text with Ctrl-C and paste it. Text moving is not recognized.
Comment 4 László Németh 2021-11-19 11:45:30 UTC
Created attachment 176359 [details]
ODT test file
Comment 5 Commit Notification 2021-11-23 10:54:55 UTC
László Németh committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/7bc57e698910e24495605bd197a6d3ab5e0be5b8

tdf#145719 sw: track moved text in import and ChangesInMargin

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 NISZ LibreOffice Team 2021-12-08 08:52:32 UTC
Verified in:
Version: 7.4.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 3a61cce54277fd12570103a191c50d9b37ef3dd3
CPU threads: 8; OS: Windows 10.0 Build 18363; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: hu-HU
Calc: CL
Comment 7 Stéphane Guillou (stragu) 2021-12-29 23:11:49 UTC
Reviewing for release notes.

Confirmed in:

Version: 7.1.8.1 / LibreOffice Community
Build ID: e1f30c802c3269a1d052614453f260e49458c82c
CPU threads: 8; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-AU (en_AU.UTF-8); UI: en-US
Calc: threaded

(deletion shown in margin, but text still shown in main text)

Verified fix in:

Version: 7.3.0.1 / LibreOffice Community
Build ID: 840fe2f57ae5ad80d62bfa6e25550cb10ddabd1d
CPU threads: 8; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-AU (en_AU.UTF-8); UI: en-US
Calc: threaded

(deletion in margin in blue, new location in green in text)

Adding meta.