Bug 145740 - Support for working with online CC0 photo gallery source images
Summary: Support for working with online CC0 photo gallery source images
Status: RESOLVED MOVED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Extensions (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86-64 (AMD64) All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: DoAsExtension
  Show dependency treegraph
 
Reported: 2021-11-17 15:28 UTC by Jesus Benjamin Yam Aguilar
Modified: 2021-11-25 09:24 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jesus Benjamin Yam Aguilar 2021-11-17 15:28:14 UTC
Description:
i think can improve, the option online images like microsoft, i see the program have now openclipart gallery, but i think some people need photograpy, the program "Affinity Designer/Photo" are softwares like photoshop and illustrator and have the option online images and can search images from pixabay, pexels, etc. Because this images are free and when insert, insert too link autor.
Other software use this website for insert, are canva.

Thanks.

Actual Results:
no bug

Expected Results:
no bug


Reproducible: Always


User Profile Reset: No



Additional Info:
hi
Comment 1 Roman Kuznetsov 2021-11-18 19:35:53 UTC
I don't think we need it

UX team?
Comment 2 Heiko Tietze 2021-11-19 08:26:42 UTC
I would appreciate such a feature as extension / 3rd party tool. 

Other opinions?
Comment 3 Cor Nouws 2021-11-24 19:16:44 UTC
fun - but far far from trivial
Comment 4 Heiko Tietze 2021-11-25 09:24:08 UTC
We discussed this topic in the design meeting. While the use case is clear and reasonable, in particular for Impress, it has some snares. First of all, linking to external sources is often doomed from the beginning since we always have to follow changes to the API. And choosing what platform to advertise is a matter of marketing. It's not FLOSS to offer only one option. That might be solved with a lot of configuration switches but with cost on usability.

Putting all together such a feature is better suited for an extension.