Bug 145757 - saving AutoRecovery information cannot be setup, turned off
Summary: saving AutoRecovery information cannot be setup, turned off
Status: RESOLVED DUPLICATE of bug 149401
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
7.3.0.0.alpha1+
Hardware: x86-64 (AMD64) Windows (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-11-18 12:40 UTC by HTK300
Modified: 2022-07-03 09:27 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
LO Options menu (68.14 KB, image/jpeg)
2021-11-18 12:45 UTC, HTK300
Details
screenshot bottom when autosaving Revovery information (167.49 KB, application/octet-stream)
2021-11-18 12:55 UTC, HTK300
Details
screenshot autosaving Revovery information (43.04 KB, image/jpeg)
2021-11-18 12:59 UTC, HTK300
Details

Note You need to log in before you can comment on or make changes to this bug.
Description HTK300 2021-11-18 12:40:50 UTC
Description:
even when the tick in [options]+General-load/save: Save AutoRecovery information every 10 min seems not be willing to be turned of. This feature and its activity is not very transparent when having many LO writer files open at the same time. Even turned off it still saves and consumes time where no editing of other open files is possible. A file of 5.000 kB takes 12-18 seconds inhibiting any other files to be edited. see attachements

Steps to Reproduce:
1. create and open more than three files (writer and/or calc)
2. files should be quite huge in its size e.g. larger than 2.000 kB
3. increase to 59 Min and turn off the 'Save AutoRecovery information every ...Min' saving feature in [Options]
4. edit files and do not save them manually
5. wait about 10 Minutes
6. even the Options to save the AutoRecovery information had earlier been turned off, it still saves it
7. This saving of AutoRecovery information inhibits any editing on other files being open, making the Window blush and at the top window title bar it appears an additional hint next to the LibreOffice Calc saying "Not Responding"
8. This should be saying "autosaving in progress"

Actual Results:
1. create and open more than three files (writer and/or calc)
2. files should be quite huge in its size e.g. larger than 2.000 kB
3. increase to 59 Min and turn off the 'Save AutoRecovery information every ...Min' saving feature in [Options]
4. edit files and do not save them manually
5. wait about 10 Minutes
6. even the Options to save the AutoRecovery information had earlier been turned off, it still saves it
7. This saving of AutoRecovery information inhibits any editing on other files being open, making the Window blush and at the top window title bar it appears an additional hint next to the LibreOffice Calc saying "Not Responding"
8. This should be saying "autosaving in progress"

Expected Results:
a) item 3. is expected to be turned off or setup of minutes be working
b) item 7. being able to edit other files is vital and a must to keep up productivity/integrity 
c) item 8. should be saying "autosaving in progress"
d) across Calc, Writer, Base it is not easy to understand, which application counts down the saving AutoRecovery. I wish to have more transperency upon this feature, wanting to see the countdown on every file being open.
e) Even, once a file has been saved, it still seems that LibreOffice continuously saving AutoRecovery information, which always stops me from editing other files for the time AutoRecovery being saved




Reproducible: Always


User Profile Reset: No



Additional Info:
all these bugs occur in macOS as well.

Saving documents automatically
==============================
LibreOffice can save files automatically as part of the AutoRecovery feature. Automatic saving, like manual saving, overwrites the last saved state of the file.

To set up automatic file saving:
1) Go to Tools > Options > Load/Save > General on the Menu bar.
2) Select Save AutoRecovery information every and set the time interval.
3) Click OK.
Comment 1 HTK300 2021-11-18 12:45:39 UTC
Created attachment 176336 [details]
LO Options menu

AutoRecovery feature setup turned off
setup to maximum 59 minutes
Comment 2 HTK300 2021-11-18 12:55:27 UTC
Created attachment 176337 [details]
screenshot bottom when autosaving Revovery information

pdf
Comment 3 HTK300 2021-11-18 12:59:17 UTC
Created attachment 176339 [details]
screenshot autosaving Revovery information
Comment 4 HTK300 2021-11-18 13:14:04 UTC
the elapsed time to have LO files autosaved, which are being larger than 2 MBytes consumes quite some time 12 seconds to complete and with 4 files being open and worked upon them does constantly interrupt the editing of other files. 

This process is not very easy to grasp. Question is, whether the saving of AutoRecovery information is a global or an individual setting for the file, the app or in General for LibreOffice, becuase I do have many different files open at the same time.
Comment 5 pharmankur 2022-05-10 17:33:33 UTC
I have exact same issue.

My Configuration --

On Linux Mint 20.2 
Version: 7.3.3.2 / LibreOffice Community
Build ID: 30(Build:2)
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-IN (en_IN); UI: en-US
Ubuntu package version: 1:7.3.3~rc2-0ubuntu0.20.04.1~lo1
Calc: threaded

User Profile Reset = YES

I often work with heavy files and autorecovery process hinders my work.
Therefore I used to do Tools --> Options --> Load/Save --> General --> Disable "Save Autorecovery information Every -- Minutes"

When I used to disable it, Autorecovery did not bother me till is used LO 7.1

But since last few updates (do not remember exact which update of LO) , It seems even if turning off this option does not DISABLE autorecovery.
Autorecovery happens once in 10 min regardless of my setting.
My LO calc sheets (usually more than 15 MB size freeze for 2 min or so once in every 10 min.

Its using calc / writer has become painful due to this arrogant feature.

Please TURN AUTORECOVERY OFF or pls tell me the way to do it myself !
Comment 6 HTK300 2022-05-11 06:24:50 UTC
this thing is even more tedious in LibreOffice 7.4.0.0 alpha
Comment 7 Buovjaga 2022-07-03 09:27:34 UTC
Looks like it was fixed as bug 149401.

*** This bug has been marked as a duplicate of bug 149401 ***