Bug 145803 - LibreOffice from 7.2 only opens in Safe Mode, UI render default no Skia on Windows 10 and 11
Summary: LibreOffice from 7.2 only opens in Safe Mode, UI render default no Skia on Wi...
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
(earliest affected) release
Hardware: All Windows (All)
: high critical
Assignee: Not Assigned
Keywords: bibisectRequest, regression
: 146835 146886 148393 149283 (view as bug list)
Depends on:
Blocks: Skia
  Show dependency treegraph
Reported: 2021-11-21 01:21 UTC by nightwriter99.9
Modified: 2023-09-22 03:16 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Note You need to log in before you can comment on or make changes to this bug.
Description nightwriter99.9 2021-11-21 01:21:46 UTC
My LibreOffice only opens in Safe mode. This has been going on since install.  I have Windows 11, but LO was installed with Windows 10 originally. I have turned off OpenCL, disabled hardware acceleration, even created a new user profile, (even though a corrupt profile would imply that the system installed it corrupt since it's always been this way). I've reinstalled LibreOffice twice. The second time I went the extra step of deleting registry items related to LO before reinstalling. 
I'm out of options and instructions and I've resolved just to use it through Safe mode. I think there is an issue with this program that cannot be fixed on my end.  Please investigate. Thank you.

Steps to Reproduce:
1.Click on LibreOffice link
2.Nothing happens.

Actual Results:
I get a spinning circle, then it disappears.

Expected Results:
The Program should open.

Reproducible: Always

User Profile Reset: Yes

Additional Info:
There's nothing else to add. It doesn't open unless in safe mode.
Comment 1 V Stuart Foote 2021-11-21 15:02:02 UTC
'delete' your user profile?

Its normally at:


Otherwise see the steps here, at the least we need you to copy paste the Help/About content and the details from your LO profile \4\cache\skia.log

process your following is here: https://wiki.documentfoundation.org/QA/FirstSteps#Graphics-related_issues_.28Skia.29
Comment 2 nightwriter99.9 2021-11-21 18:12:05 UTC
Thanks for your advice. Unfortunately, it's a no-go. Deleting the profile didn't do anything. And the instructions in the link don't apply. "UI Render: Skia/Vulkan" doesn't exist for me. I've got: "UI Render: default; VCL:win" instead.
Comment 3 QA Administrators 2021-11-22 04:02:19 UTC Comment hidden (obsolete)
Comment 4 V Stuart Foote 2021-11-22 13:57:44 UTC
So, seems the issue is skia driver support on Windows 11?

Do you get clean launch with default GDI+ only launch by disabling Skia rendering?

Tools -> Options -> View panel and uncheck both the "Use Skia for all rendering" and the "Force Skia software rendering"--the first to disable Skia Vulkan acceleration, the second prevents fallback to Skia lib raster only rendering.

We do still need to know your GPU and driver details.

GPU and driver should be in a run of msinfo32.exe from the Component -> Display panel.

Getting the Vulkan driver details may require a third party program (if it runs) realtech-VR's glview program from https://www.realtech-vr.com/home/glview should provide the Vulkan driver and GPU details.
Comment 5 nightwriter99.9 2021-11-22 23:15:59 UTC
"Do you get clean launch with default GDI+ only launch by disabling Skia rendering?"

I don't know.  I'm just a writer with slightly above basic computer knowledge. I have no idea what you mean.

However, I did try this:

"Tools -> Options -> View panel and uncheck both the "Use Skia for all rendering" and the "Force Skia software rendering"--the first to disable Skia Vulkan acceleration, the second prevents fallback to Skia lib raster only rendering."

And no change.

"We do still need to know your GPU and driver details."

Okay. Here you go:

Name	Intel(R) UHD Graphics
PNP Device ID	PCI\VEN_8086&DEV_9B41&SUBSYS_095E1028&REV_02\3&11583659&0&10
Adapter Type	Intel(R) UHD Graphics Family, Intel Corporation compatible
Adapter Description	Intel(R) UHD Graphics
Adapter RAM	1.00 GB (1,073,741,824 bytes)
Installed Drivers	C:\WINDOWS\System32\DriverStore\FileRepository\iigd_dch.inf_amd64_957181f5db7f35b4\igdumdim64.dll,C:\WINDOWS\System32\DriverStore\FileRepository\iigd_dch.inf_amd64_957181f5db7f35b4\igd10iumd64.dll,C:\WINDOWS\System32\DriverStore\FileRepository\iigd_dch.inf_amd64_957181f5db7f35b4\igd10iumd64.dll,C:\WINDOWS\System32\DriverStore\FileRepository\iigd_dch.inf_amd64_957181f5db7f35b4\igd12umd64.dll
Driver Version
INF File	oem70.inf (iCML_w10_DS section)
Color Planes	Not Available
Color Table Entries	4294967296
Resolution	1920 x 1080 x 60 hertz
Bits/Pixel	32
Memory Address	0x0000-0xFFFFFF
Memory Address	0x0000-0xFFFFFFF
I/O Port	0x00003000-0x0000303F
IRQ Channel	IRQ 4294967260
Driver	C:\WINDOWS\SYSTEM32\DRIVERSTORE\FILEREPOSITORY\IIGD_DCH.INF_AMD64_957181F5DB7F35B4\IGDKMD64.SYS (, 18.88 MB (19,800,632 bytes), 1/4/2020 8:51 PM)
Comment 6 V Stuart Foote 2021-11-23 00:33:52 UTC
(In reply to nightwriter99.9 from comment #5)
> Driver Version

That driver is rather out of date for a Windows 11 installation, DCH packaging would be current for your Coffee Lake GPU.

Download from Intel is available here:


Update and see if that improves things...
Comment 7 nightwriter99.9 2021-11-23 11:53:00 UTC
Updated! (yay!)
Still nothing! (boo!)

I installed the drivers and even restarted the computer after. Still won't open any other way than safe mode.
Comment 8 QA Administrators 2021-11-24 04:32:01 UTC Comment hidden (obsolete)
Comment 9 Timur 2022-01-20 07:00:41 UTC
*** Bug 146835 has been marked as a duplicate of this bug. ***
Comment 10 Timur 2022-01-21 11:26:52 UTC
*** Bug 146886 has been marked as a duplicate of this bug. ***
Comment 11 mematuszewski 2022-02-26 06:25:12 UTC
Good morning.

I, too, have been having issues with Windows 11 and LibreOffice.  All of the applications crash upon launch.  I observe a brief Window of the application, and then they all crash at the same time.  This is on a new ASUS ROG Zephyrus G14 (2022) RJ2 laptop with the Ryzen 6900HS, Radeon 6700S GPU.
Comment 12 Timur 2022-02-26 14:47:52 UTC
I retitle as I understand this based on this one and duplicates. 
7.1 worked, doesn't work from 7.2,both in Windows 10 and 11, probably for some graphic cards.
Comment 13 Timur 2022-03-31 06:19:40 UTC
So you who have this problem, what did you do? Reverted to LO 7.1?
Please install daily master 7.4+ for test from https://dev-builds.libreoffice.org/daily/master/current.html. It installs in addition to working LO and doesn't take extensions. 
Please run normally and if it doesn't work, run from Command (replacing path-to) with:
Comment 14 Timur 2022-04-06 07:41:18 UTC
*** Bug 148393 has been marked as a duplicate of this bug. ***
Comment 15 Timur 2022-05-25 20:17:25 UTC
*** Bug 149283 has been marked as a duplicate of this bug. ***
Comment 16 Matt K 2022-07-27 02:02:57 UTC
No repro for me on latest master build on 64-bit Windows 11 both with or without Skia.  Here are the details:

Version: (x64) / LibreOffice Community
Build ID: 4d42aeae86253e167facb1adfddd0c9976b7801a
CPU threads: 12; OS: Windows 10.0 Build 22000; UI render: Skia/Vulkan; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: CL

Name	NVIDIA GeForce GTX 1080 Ti
Driver Version
Comment 17 Timur 2022-07-27 07:10:22 UTC
This is a bug that only affects some users. So, it's important to reproduce with their version LO 7.2 and then then with master LO 7.5+.
Comment 18 joerg.behrschmidt@8p2.de 2022-07-27 07:27:39 UTC
At the moment I work with version and windows 10.0 Build 19044. The version before I do not remember. But it was an update to solve the problem of 7.2.

On 13th of June after the update of windows to Build 19044  I had the same problems, which had been solved with the update of Libre to version
Comment 19 Timur 2022-07-28 07:42:53 UTC
Joerg from Bug 149283 thanks, I understand all is good for you now. 

That justifies setting this bug to Needinfo so that others in CC write their status and Windows and LO versions and test with and without Skia. 
LO should be
Comment 20 QA Administrators 2023-01-25 03:19:44 UTC Comment hidden (obsolete)
Comment 21 Grateful User 2023-02-20 20:19:27 UTC
I have had a similar problem.  Libre office (7.3??) would often fail to open by clicking on the desktop file icon and I had to open the file fron inside Libre Office.  Then, after a computer crash, I could not open any libre office files at all.  I got the circulating timer for a couple of seconds and then nothing.  Installing version 7.5 made no difference, but uninstalling version 7.5 with the uninstall facility on the control panel and then installing version 7.4.5 fixed the problem.  Perhaps a fault in a configuration that does not get overwritten on the installation of a new version?
Comment 22 Stéphane Guillou (stragu) 2023-02-22 11:34:22 UTC
It would be great if people affected by this bug could test version 7.5.1 to see if the issue is resolved by the fix for bug 153641. I'm aware this is supposed to catch Skia-related issues but I'm wondering if some duplicates and CCs are unrelated to Skia.

Download from: https://www.libreoffice.org/download/download-libreoffice/?version=7.5.1
Comment 23 QA Administrators 2023-08-22 03:06:05 UTC Comment hidden (obsolete)
Comment 24 QA Administrators 2023-09-22 03:16:52 UTC
Dear nightwriter99.9,

Please read this message in its entirety before proceeding.

Your bug report is being closed as INSUFFICIENTDATA due to inactivity and
a lack of information which is needed in order to accurately
reproduce and confirm the problem. We encourage you to retest
your bug against the latest release. If the issue is still
present in the latest stable release, we need the following
information (please ignore any that you've already provided):

a) Provide details of your system including your operating
   system and the latest version of LibreOffice that you have
   confirmed the bug to be present

b) Provide easy to reproduce steps – the simpler the better

c) Provide any test case(s) which will help us confirm the problem

d) Provide screenshots of the problem if you think it might help

e) Read all comments and provide any requested information

Once all of this is done, please set the bug back to UNCONFIRMED
and we will attempt to reproduce the issue. Please do not:

a) respond via email 

b) update the version field in the bug or any of the other details
   on the top section of our bug tracker

Warm Regards,
QA Team