Bug 145839 - Calc crashes when applying filter to a column in an xlsx file
Summary: Calc crashes when applying filter to a column in an xlsx file
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.2.2.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL: https://www.iso20022.org/data-field-d...
Whiteboard:
Keywords: filter:xlsx, haveBacktrace
Depends on:
Blocks: Calc-large-spreadsheets
  Show dependency treegraph
 
Reported: 2021-11-22 20:41 UTC by bednarczyk.pawel
Modified: 2022-02-14 11:03 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
gdbtrace (21.49 KB, text/x-log)
2021-11-22 20:48 UTC, bednarczyk.pawel
Details
sample file (399.85 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2021-11-23 09:49 UTC, Xisco Faulí
Details
bt with debug symbols (7.21 KB, text/plain)
2021-11-23 20:55 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bednarczyk.pawel 2021-11-22 20:41:59 UTC
Libre Office Calc crashes when working with an xlsx file from the ISO2022 website.

1. Navigate to https://www.iso20022.org/data-field-dictionary
2. Download the Data Field Dictionary spreadsheet: https://www.iso20022.org/sites/default/files/2021-02/ISO15022_Data_Field_Dictionary.xlsx
3.Open the spreadsheet in Calc
4. Navigate to the Generic Fields sheet
5.Create a filter on column A (Business Class)
6. Deselect ALL and select the Date/Time value
7. Calc Crashes 

In fact, any value from column A seems to crash the application. 

Version: 7.2.2.2 / LibreOffice Community
Build ID: 20(Build:2)
CPU threads: 16; OS: Linux 5.13; UI render: default; VCL: kf5 (cairo+wayland)
Locale: en-US (en_US.UTF-8); UI: en-US
7.2.2-4
Calc: threaded Jumbo
Comment 1 bednarczyk.pawel 2021-11-22 20:48:02 UTC
Created attachment 176430 [details]
gdbtrace

+ gdbtrace, but I don't know how useful that is
Comment 2 Xisco Faulí 2021-11-23 09:48:56 UTC
Reproduced in

Version: 7.3.0.0.alpha1+ / LibreOffice Community
Build ID: 5a00326951690d820d8ea5412a93aadf3da42dc1
CPU threads: 4; OS: Linux 5.10; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded Jumbo

only when using jumbo sheets.

Please, be aware this feature is experimental and it shouldn't be used in production environments
Comment 3 Xisco Faulí 2021-11-23 09:49:22 UTC
Created attachment 176443 [details]
sample file
Comment 4 bednarczyk.pawel 2021-11-23 10:02:26 UTC
thanks! I can confirm disabling very large sheets in Calc solves the problem. I have done just that for now.
Comment 5 Julien Nabet 2021-11-23 20:55:37 UTC
Created attachment 176455 [details]
bt with debug symbols

On pc Debian x86-64 with master sources updated today, I could reproduce this.
Comment 6 Luboš Luňák 2022-02-14 11:03:32 UTC
Works for me with current master (and crashes with a slightly older build), presumably fixed by one of my recent fixes.