Bug 145924 - Shortcuts for Alt+… are also connected to Ctrl+Alt+… (Linux, gtk3 and gen, not kf5)
Summary: Shortcuts for Alt+… are also connected to Ctrl+Alt+… (Linux, gtk3 and gen, no...
Status: RESOLVED DUPLICATE of bug 147062
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
7.2.0.4 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-11-28 08:34 UTC by Robert Großkopf
Modified: 2022-02-20 03:35 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Großkopf 2021-11-28 08:34:21 UTC
Open LO 7.2.3.2 under Linux with SAL_USE_VCLPLUGIN=gen ./soffice.
Try Alt + F → menu 'File' will be opened.
Try Ctrl + Alt + F → menu 'File' will be opened also.
This behavior appears for 'Help' and many menus when opening an empty writer document (View, Insert, Format …).

Same behavior when LO 7.2.3.2 is opened with vcl:gtk3.
With vcl:kf5 the combination of Ctrl + Alt + F won't open the menu 'File' and all the other menus. This is the expected behavior.

All tested on the same machine, OpenSUSE 15.2 64bit rpm Linux.

Bug appears also in LO 7.2.0.4. Could be it is the default behavior of vcl:gen, because it also appears for vcl.gen with LO 7.0.0.
Comment 1 Michael Warner 2022-02-19 14:12:02 UTC

*** This bug has been marked as a duplicate of bug 147062 ***