Bug 145926 - referenced table values will be invalid if table is renamed in writer
Summary: referenced table values will be invalid if table is renamed in writer
Status: RESOLVED DUPLICATE of bug 105312
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.2.2.2 release
Hardware: All All
: medium normal
Assignee: stefan.hinderberger
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-11-28 11:00 UTC by stefan.hinderberger
Modified: 2021-12-15 17:53 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
demo document (80.01 KB, application/vnd.oasis.opendocument.text)
2021-12-13 19:57 UTC, stefan.hinderberger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description stefan.hinderberger 2021-11-28 11:00:42 UTC
Description:
If one table funktion reference to other table in libreoffice writer and table is renamed the function with reference is invalid, because tablename in formula is not updated.

Steps to Reproduce:
1. create 2 tables in writer
2. set a function in one table which references to value of other table
3. rename the referenced table

Actual Results:
function get invalid because referenced table name is not updated

Expected Results:
referenced table name should be updated automatic


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.2.2.2 (x64) / LibreOffice Community
Build ID: 02b2acce88a210515b4a5bb2e46cbfb63fe97d56
CPU threads: 8; OS: Windows 10.0 Build 19044; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: de-DE
Calc: threaded
Comment 1 Dieter 2021-12-13 07:25:20 UTC
Stefan, thank you for reporting the bug. Please attach a sample document and some steps to reproduce, as this makes it easier for us to verify the bug. 
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested document is provided.
(Please note that the attachment will be public, remove any sensitive information before attaching it)
Comment 2 stefan.hinderberger 2021-12-13 19:57:39 UTC
Created attachment 176916 [details]
demo document
Comment 3 stefan.hinderberger 2021-12-13 19:58:29 UTC
description is in document
Comment 4 Dieter 2021-12-15 17:53:39 UTC
I confirm it and this is bug 105312

*** This bug has been marked as a duplicate of bug 105312 ***