Bug 145977 - Modules shown in the Macro Selector should be sorted alphabetically
Summary: Modules shown in the Macro Selector should be sorted alphabetically
Status: RESOLVED DUPLICATE of bug 97169
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
7.2.2.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Macro-UI
  Show dependency treegraph
 
Reported: 2021-11-30 20:37 UTC by Rafael Lima
Modified: 2021-12-06 12:48 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshots showing the problem (135.67 KB, application/vnd.oasis.opendocument.graphics)
2021-11-30 20:37 UTC, Rafael Lima
Details
Screenshot of the "Macro Organizer" dialog which sorts correctly (108.64 KB, image/png)
2021-11-30 20:47 UTC, Rafael Lima
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rafael Lima 2021-11-30 20:37:14 UTC
Created attachment 176608 [details]
Screenshots showing the problem

Open the macro selector (Tools - Macros - Run Macro) and open a library containing many modules. Now notice that the modules are not sorted at any particular order (see examples in the attached ODG file).

IMO it would be better if module names were sorted alphabetically.

Also, the names of the libraries are sorted alphabetically in ascending order, however in a case-sensitive fashion: all capital letters coming before small letters. Maybe it would be better to sort alphabetically without considering case-sensitiveness.
Comment 1 Rafael Lima 2021-11-30 20:47:43 UTC
Created attachment 176610 [details]
Screenshot of the "Macro Organizer" dialog which sorts correctly

Interestingly, the Macro Organizer dialog (Tools - Macros - Organize Macros - Basic) sorts macros correctly (see attached image).

We just need to replicate this behavior to the Macro Selector dialog.
Comment 2 Heiko Tietze 2021-12-06 12:48:31 UTC

*** This bug has been marked as a duplicate of bug 97169 ***