Bug 146047 - UI: Orientation Landscape in Print dialog doesn't do anything
Summary: UI: Orientation Landscape in Print dialog doesn't do anything
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.4.0.0 alpha0+ Master
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks: Print-Dialog
  Show dependency treegraph
 
Reported: 2021-12-04 14:06 UTC by Telesto
Modified: 2022-04-04 10:11 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file (13.41 KB, application/vnd.oasis.opendocument.text)
2021-12-04 14:06 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2021-12-04 14:06:10 UTC
Description:
UI: Orientation Landscape in Print dialog doesn't do anything

Steps to Reproduce:
1. Open the attached file
2. Press Print button
3. Change orientation from automatic to Landscape

Actual Results:
Still portrait

Expected Results:
Landscape? Still no clue how this supposed to work: see bug 145354


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.4.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: ddc57169ac8d1de00403dbb09fef5221beaa0f3d
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 1 Telesto 2021-12-04 14:06:23 UTC
Created attachment 176693 [details]
Example file
Comment 2 Telesto 2021-12-04 14:12:07 UTC
Still ok with
Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 7ec1ef958855ba7ebff4d3bc623f454015ec5a5c
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL

those settings didn't exist
Version: 6.2.9.0.0+ (x86)
Build ID: 5f01fe15eb2661f1f9ce12d1d99dc2a705b462ee
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: CL
Comment 3 Telesto 2021-12-04 14:22:09 UTC
@Tor
Pre-warning: there is some fall-out left & right. At this point in time only speculative (without bibisect), but likely related to bug 145354

The easiest thing is to do is getting rid of the whole "Page Layout" part in the dialog. It's probably not flying; if I understand it correctly (bug 143354) (or limited to certain environments; but not working for Windows

It's newly added in 6.3 branch (Print Dialog revamp). 

And well the revamp wasn't big success either with all those + expand elements (the UI space can be used for functional stuff, IMHO)
Comment 4 Telesto 2021-12-04 23:42:57 UTC
@Heiko
I get strong feeling you should remove the page layout section (attachment 176697 [details]) including 'landscape orientation) out of the dialog.

The number of developers involved to make it work and their frustration about not getting it to work is driving developers into insanity. And I get rather annoyed by reporting flaws. And the end-user likely get annoyed because it's working unpredictable

I makes everybody unhappy. 

FWIW: there are two problems
A) The preview dialog is not responding properly to defined page sizes in document
B) Setting not being applied when actually printing in plenty of cases (setting print size to A3 on A4 printer). 

I don't expect you get any developer working on this voluntary anytime soon. And this feature is rather new.. A revert/removal seems the sane solution in my perception.
Comment 5 Julien Nabet 2021-12-05 19:44:27 UTC
Just for the record, on pc Debian x86-64 with master sources updated today (9d08f3363188d446b287c445f1ab09339c65d208), I could reproduce this.
I don't reproduce this with LO Debian testing package 7.2.3.2
Comment 6 Julien Nabet 2021-12-05 20:16:14 UTC
(In reply to Telesto from comment #4)
> @Heiko
> I get strong feeling you should remove the page layout section (attachment
> 176697 [details]) including 'landscape orientation) out of the dialog.
> 
> The number of developers involved to make it work and their frustration
> about not getting it to work is driving developers into insanity. And I get
> rather annoyed by reporting flaws. And the end-user likely get annoyed
> because it's working unpredictable
>...

In the same time, having page layout is relevant in a print dialog, in the other side, Tor is an LO expert dev and usually doesn't give up so for me it can only mean there's something really wrong or at least very tricky in the code.
IMHO it should be discussed in ESC. I mean perhaps Tor's work just revealed some nasty bugs and just reverting his work would hide them again.
Now I understand the regressions that appear must be taken into account and not be left aside for several months (or worse!).

Caolán: I know that welding process allows some homogenisation in UI display and UI code so I took a look at git history of vcl/source/window/printdlg.cxx, I noticed:
"weld PrintDialog" in October 2019 but also  "weld PrintProgressDialog" and "weld MoreOptionsDialog" earlier in 2019 and some fixes after October 2019.
I just wonder if the welding process is over for printing part and also if you had you noticed some fishy code to fix/refactor later which may explain this situation?
Comment 7 Aron Budea 2021-12-06 01:36:35 UTC
Still OK in LO 11-23 daily build: 7.3.0.0.alpha1+ (dcc890e3b00ec174f4c752199ec54a8d873aaf8e).
The revert in bug 145354 happened on 11-24.
Comment 8 Heiko Tietze 2021-12-06 09:14:40 UTC
Works for me in 

Version: 7.2.3.2 / LibreOffice Community
Build ID: 20(Build:2)
CPU threads: 8; OS: Linux 5.15; UI render: default; VCL: kf5 (cairo+xcb)
Locale: de-DE (en_US.UTF-8); UI: en-US
7.2.3-1
Calc: threaded

but not with

Version: 7.4.0.0.alpha0+ / LibreOffice Community
Build ID: e9f3a5dcca93d2b53d291587600fb460665ff46b
CPU threads: 8; OS: Linux 5.15; UI render: default; VCL: kf5 (cairo+xcb)
Locale: de-DE (en_US.UTF-8); UI: en-US
Calc: threaded

Changing the orientation of a print out is an essential function. We cannot just remove it.
Comment 9 Telesto 2021-12-06 09:34:04 UTC
(In reply to Heiko Tietze from comment #8)
> Changing the orientation of a print out is an essential function. We cannot
> just remove it.

I'm possible bit rigorous. I'm still trying to understand the model/design of this. And the cases this being required.

The current print dialog in LibO has similar to Print Preview a Chromium based browser. It works. Except this can't be 1:1 moved to LibreOffice ; Different components have different capability's which make much harder to have such a setting.

A Writer Document has multiple pages. Orientation (Portrait/Landscape) can be defined for every page individually. The same is the case for paper size. Which can be defined for each page too.

In those cases a single drop down where you change orientation (or paper size) this will overrule all individual settings for all pages. Intended? 

In case of Impress this likely works out as intended 

Calc: no clue..

Draw: well there is some request to set page orientation/size individually. Which makes sense, IMHO. So currently it behaves as Impress, but don't think that's the long term goal.
Comment 10 Justin L 2021-12-09 06:38:12 UTC
(In reply to Heiko Tietze from comment #8)
> Changing the orientation of a print out is an essential function. We cannot
> just remove it.
This is especially true when you use the print dialog to combine multiple pages on one page, make a brochure, or things like that. Heiko is right, you can't just remove it.
Comment 11 Julien Nabet 2022-02-07 21:33:24 UTC
Just for the record, I could reproduce this with LO Debian package 7.3.0.2 but I don't reproduce this with master sources updated today.

For "Generic printer", preview shows landscape.
For "Print to file", preview shows landscape and the file generated shows also landscape.
Comment 12 Justin L 2022-04-01 11:11:31 UTC
I couldn't reproduce this at all now with Linux bibisect 7.4 - even on the commits that others mentioned were bad.

comment 11 indicates this seems to be fixed in master.

OP - please retest.
Comment 13 Telesto 2022-04-04 10:11:21 UTC
Can't repro it either
Version: 7.4.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 52ef78f4923283e6e52d575bec81985b031cb30b
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL Jumbo