Bug 146062 - UI gets blocked while downloading new icon theme
Summary: UI gets blocked while downloading new icon theme
Status: UNCONFIRMED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.2.3.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Icon-Themes
  Show dependency treegraph
 
Reported: 2021-12-05 15:10 UTC by rahul sahoo
Modified: 2021-12-23 14:47 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rahul sahoo 2021-12-05 15:10:26 UTC
When a new icon theme is getting downloaded/installed from Settings -> View -> Icon Style (side button which allows to download new icon themes). The whole UI gets hanged until the theme is installed.
Comment 1 Dieter 2021-12-20 08:24:59 UTC
Thank you for reporting the bug. It seems you're using an old version of LibreOffice. Could you please try to reproduce it with the latest version of LibreOffice from https://www.libreoffice.org/download/libreoffice-fresh/ ? I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the latest version. Change to RESOLVED WORKSFORME, if the problem went away.
Comment 2 rahul sahoo 2021-12-22 11:41:18 UTC
I have updated the libre office. Now its LibreOffice 7.2.3.2 20(Build:2). I did check the issue. Now its not hanged but Force Quit/Wait dialog box appears. Now the download and installation is quick so its not quite noticeable.
Comment 3 QA Administrators 2021-12-23 04:29:37 UTC Comment hidden (obsolete)
Comment 4 Dieter 2021-12-23 14:47:41 UTC
I can't confirm it with

Version: 7.2.4.1 (x64) / LibreOffice Community
Build ID: 27d75539669ac387bb498e35313b970b7fe9c4f9
CPU threads: 4; OS: Windows 10.0 Build 19044; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: CL

Installation works and icon style appears is list after restart of LO. No dialog box appears (but perhaps it would be nice, if a dialog like "Icon style installed. Ready for user after restart. Do you want to restart Lo now? Yes/No" (or something like that).