Bug 146064 - writer image insertion use relative paths by default UI
Summary: writer image insertion use relative paths by default UI
Status: RESOLVED DUPLICATE of bug 128216
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All Windows (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-12-05 18:31 UTC by pb
Modified: 2021-12-06 18:48 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pb 2021-12-05 18:31:27 UTC
It would be helpful if there were a setting such that linked images were stored as relative paths, rather than absolute paths, by default. 

The value is that it would then make it easy to hand someone a usb stick with the  document and its images without any extra work other than copying directory structure involved.

(I am using Windows;  may apply to other OS's, I don't know.)(Also, might apply to other components;  I have not checked.)

Why not embed images?  Because:

1.  With a lot of images, the document becomes enormous.
2.  I have found endless bugs that trash the document if there are too many embedded images.  That was true for me in versions 6.4.3, and 7.2.2.

LO 7.2.3, win 7.
Comment 1 m.a.riosv 2021-12-06 03:00:25 UTC
What about the option:
Menu/Tools/Options/LIbre Office/Load & Save/General - Save URLs relative to file system.
Comment 2 pb 2021-12-06 17:36:17 UTC
Thanks.  That box is already checked in my install.

Nevertheless, the properties dialog for pictures shows absolute file names.

In the documentation, it says:

"...LibreOffice uses absolute path names internally. The complete path and address can only be seen when you view the result of the HTML export, by loading the HTML file as "Text" or opening it with a text editor."

If that is the situation for images inserted with a link, I don't see a way to test how the link is being stored.  However, I did look inside the odt file, and indeed the link is being stored as relative in content.xml.

So, I need to change my request.  The problem is that the properties dialog shows an absolute path, but actually a relative path is being used if that setting is in force.  The properties dialog should include a notation that relative file name saving is in force, or absolute file name saving is in force, and it would be even better if there were a way in that dialog to toggle that, both for just this one file, or for all links.  

The current properties dialog leaves the impression that the files are stored absolute, and the documentation I cited seems to only apply to hyperlinks in the text.
Comment 3 m.a.riosv 2021-12-06 18:48:44 UTC

*** This bug has been marked as a duplicate of bug 128216 ***